Bug 1162068 - High Xorg cpu usage during F21 beta install prevents installation
Summary: High Xorg cpu usage during F21 beta install prevents installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F21FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2014-11-10 08:19 UTC by Hedayat Vatankhah
Modified: 2014-11-28 09:48 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-24 00:32:30 UTC
Type: Bug


Attachments (Terms of Use)
updates(WRONG).img (786.81 KB, application/octet-stream)
2014-11-20 18:48 UTC, Marian Csontos
no flags Details

Description Hedayat Vatankhah 2014-11-10 08:19:00 UTC
Description of problem:
Notice: I doubt this is an Anaconda bug, but I'm not sure what is causing this. Could be a kernel/Xorg bug too.

I'm trying to install Fedora 21 Workstation Beta, and after configuring partitions in partitioning spoke and pressing Done, installer hangs. In this situation, keyboard buttons stop working. I can't even use Alt+Ctrl+Fn to get to virtual consoles. Mouse is working though. They only way I had to get out of this situation was hard poweroff.

Therefore, I logged in into live environment, and enabled ssh server, so that I could access the system using ssh. Using ssh, I didn't see any strange logs from Anaconda, however when I press "Done", I can see that Xorg.bin is taking almost 100% cpu. I tried it several times, and always seen same behavior. However, once I saw some errors in journalctl output which is given below. 

Also, in previous tries I always selected to reformat installation targets. In one situation, I changed the mount point but forgot to check "reformat" box. When I selected "Update Settings", anaconda stopped with the same symptoms (so I didn't get to even press Done). 

To be more complete, I should say that once I started installation, but quit the installer before reaching those steps. Then, I saw a notification about gnome-shell crash. I selected "report", and it opened a dialog asking about sending anonymous crash reports without confirmation. But, I was unable to do anything again, and was forced to do a hard poweroff. I didn't have ssh access this time, but it looks like that it was the same problem (Xorg.bin taking 100% cpu)

How reproducible:
100%

Steps to Reproduce:
1. Boot F21 live workstation beta
2. configure partitining manually and press Done

Actual results:
Anaconda hangs

Expected results:
Can proceed with the installation

Additional info:
Once, I got these errors in journalctl:

Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) [mi] EQ overflowing.  Additional events will be discarded until existing events are processed.
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE)
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) Backtrace:
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 0: /usr/libexec/Xorg.bin (mieqEnqueue+0x24b) [0x578f9b]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 1: /usr/libexec/Xorg.bin (QueuePointerEvents+0x52) [0x450952]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 2: /usr/lib64/xorg/modules/input/evdev_drv.so (_init+0x3042) [0x7f6f1d0cf852]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 3: /usr/lib64/xorg/modules/input/evdev_drv.so (_init+0x3505) [0x7f6f1d0d09a5]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 4: /usr/libexec/Xorg.bin (DPMSSupported+0xe8) [0x4772c8]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 5: /usr/libexec/Xorg.bin (xf86SerialModemClearBits+0x277) [0x4a1cc7]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 6: /lib64/libc.so.6 (__restore_rt+0x0) [0x7f6f2383194f]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 7: /lib64/libc.so.6 (ioctl+0x7) [0x7f6f238f3957]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 8: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x8354) [0x7f6f1f087094]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 9: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x963c) [0x7f6f1f08965c]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 10: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x107cd) [0x7f6f1f09758d]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 11: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x60995) [0x7f6f1f136c15]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 12: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x23bd3) [0x7f6f1f0be043]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 13: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x28db2) [0x7f6f1f0c8442]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 14: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x46716) [0x7f6f1f103746]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 15: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x46e72) [0x7f6f1f104502]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 16: /usr/libexec/Xorg.bin (DamageRegionAppend+0x541) [0x51eb41]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 17: /usr/libexec/Xorg.bin (AddTraps+0x4074) [0x518374]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 18: /usr/libexec/Xorg.bin (SendErrorToClient+0x2f7) [0x439027]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 19: /usr/libexec/Xorg.bin (remove_fs_handlers+0x416) [0x43d186]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 20: /lib64/libc.so.6 (__libc_start_main+0xf0) [0x7f6f2381cfe0]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 21: /usr/libexec/Xorg.bin (_start+0x29) [0x42761e]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 22: ? (?+0x29) [0x29]
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE)
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) [mi] These backtraces from mieqEnqueue may point to a culprit higher up the stack.
Nov 11 02:18:38 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) [mi] mieq is *NOT* the cause.  It is a victim.
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) [mi] EQ overflow continuing.  100 events have been dropped.
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE)
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) Backtrace:
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 0: /usr/libexec/Xorg.bin (QueuePointerEvents+0x52) [0x450952]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 1: /usr/lib64/xorg/modules/input/evdev_drv.so (_init+0x3042) [0x7f6f1d0cf852]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 2: /usr/lib64/xorg/modules/input/evdev_drv.so (_init+0x3505) [0x7f6f1d0d09a5]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 3: /usr/libexec/Xorg.bin (DPMSSupported+0xe8) [0x4772c8]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 4: /usr/libexec/Xorg.bin (xf86SerialModemClearBits+0x277) [0x4a1cc7]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 5: /lib64/libc.so.6 (__restore_rt+0x0) [0x7f6f2383194f]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 6: /lib64/libc.so.6 (ioctl+0x7) [0x7f6f238f3957]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 7: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x8354) [0x7f6f1f087094]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 8: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x963c) [0x7f6f1f08965c]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 9: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x107cd) [0x7f6f1f09758d]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 10: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x60995) [0x7f6f1f136c15]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 11: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x23bd3) [0x7f6f1f0be043]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 12: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x28db2) [0x7f6f1f0c8442]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 13: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x46716) [0x7f6f1f103746]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 14: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x46e72) [0x7f6f1f104502]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 15: /usr/libexec/Xorg.bin (DamageRegionAppend+0x541) [0x51eb41]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 16: /usr/libexec/Xorg.bin (AddTraps+0x4074) [0x518374]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 17: /usr/libexec/Xorg.bin (SendErrorToClient+0x2f7) [0x439027]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 18: /usr/libexec/Xorg.bin (remove_fs_handlers+0x416) [0x43d186]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 19: /lib64/libc.so.6 (__libc_start_main+0xf0) [0x7f6f2381cfe0]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 20: /usr/libexec/Xorg.bin (_start+0x29) [0x42761e]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE) 21: ? (?+0x29) [0x29]
Nov 11 02:18:39 hvlap.hvnetwork gdm-Xorg-:0[1019]: (EE)

Comment 1 Hedayat Vatankhah 2014-11-10 08:25:33 UTC
Oops, this time Anaconda crashed completely when I reached manual partitioning spoke (without applying anything). 


same backtrace as above produced.

Comment 2 Hedayat Vatankhah 2014-11-10 08:42:57 UTC
As I can't proceed with the installation (I've waited several minutes with no results), I'd propose it as a final blocker.

Notice that I've already installed F21 Workstation Alpha, so the bug has been introduced in Beta.

Comment 3 David Shea 2014-11-10 14:46:43 UTC
(In reply to Hedayat Vatankhah from comment #0)
> Description of problem:
> Notice: I doubt this is an Anaconda bug

Then don't file it against anaconda!

Comment 4 Kamil Páral 2014-11-12 18:14:57 UTC
Discussed at today's blocker review meeting [1]. We decided to punt this bug. We'd like to have more information before deciding on this bug. Could you provide the following information so we can try to reproduce? CPU, RAM, graphics stack, baremetal or VM? Thanks.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2014-11-12/

Comment 5 Hedayat Vatankhah 2014-11-12 18:40:21 UTC
Brief: Baremetal install on Thinkpad X61

Some details:
CPU: Intel(R) Core(TM)2 Duo CPU     T7100  @ 1.80GHz
RAM: 4GB
VGA: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller

Comment 6 JMlich 2014-11-18 07:43:36 UTC
Might this got fixed via bug 1148493 ?

Comment 7 Hedayat Vatankhah 2014-11-18 16:34:04 UTC
It seems very similar. How can I confirm that? I have a working F21 alpha installation (without any updates), so I can update it and see if everything works fine. But does it mean that installation will work fine too? :P 
If there are any TC builds which contain that xorg package, I can try that.

Comment 8 Marian Csontos 2014-11-19 13:48:57 UTC
I have seen the same on Thinkpad T61 installing F21Beta via netinst iso.
It "hung" when entering root password twice.
The third attempt installing and entering root password only after everything else was completed succeeded.

Also after installation I am experiencing appalling performance in Gnome (playing video is like a slideshow) which I solved by switching to LXDE which did the trick for me (though fullscreen is still not possible).

Unless someone beats me and if I have a chance I will check gnome with updated Xorg and if there is a test-compose available including the package I may try install scenario too. But it is pretty likely a duplicate of the Bug1148493.

Comment 9 Kamil Páral 2014-11-19 17:32:58 UTC
Hedyat, can you please try this image?
https://kojipkgs.fedoraproject.org//work/tasks/5751/8185751/Fedora-Live-Workstation-x86_64-21-20141119.iso

It should have the fixed intel driver inside.

Comment 10 Mike Ruckman 2014-11-19 17:36:33 UTC
Discussed in 2014-11-19 blocker review meeting. It is possible that this bug was already resolved. We will wait for more information again.

Comment 11 Marian Csontos 2014-11-20 18:48:58 UTC
Created attachment 959463 [details]
updates(WRONG).img

I planned to try install with the attached update file but the offended T61 machine is now busy.

Comment 12 Adam Williamson 2014-11-21 23:29:38 UTC
The updated xorg-x11-drv-intel should be included in Final TC3 when it arrives.

Comment 13 Marian Csontos 2014-11-22 15:54:41 UTC
Just tried TC3 which fixed the issue on my T61. Thanks!

Comment 14 Adam Williamson 2014-11-24 00:32:30 UTC
The update went stable already, so let's close this out.

Comment 15 Hedayat Vatankhah 2014-11-28 09:48:06 UTC
Yes, I tried TC4 and the issue is fixed indeed! :)


Note You need to log in before you can comment on or make changes to this bug.