Bug 116214 - Dictionary entry widget on panel won't take focus
Dictionary entry widget on panel won't take focus
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Depends On:
Blocks: FC2Target
  Show dependency treegraph
Reported: 2004-02-18 22:54 EST by John Ellson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-05-25 16:06:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description John Ellson 2004-02-18 22:54:28 EST
Description of problem:
It is not possible to enter a dictionary lookup, or even to obtain
a cursor, in the dictionary lookup widget on the panel.
Click on it and it fails to accept focus.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.add-to-panel -> accessories ->dictionary-lookup
2.click on entry box 
Actual results:
fils to accept focus

Expected results:
ability to enter lookup term into widget on panel.

Additional info:
Comment 1 Daniel Reed 2004-02-24 09:23:43 EST
This only occurs when there are open windows on the desktop; if you
close all open windows, or simply minimize them, the dictionary should
immediately accept focus. A short-term workaround would be to minimize
all windows when you need to use the dictionary, but I will look into
Comment 2 John Ellson 2004-02-24 11:35:34 EST
Interesting, except that I had to close all windows on all six
desktops; not just the current desktop.  Not a very satisfactory
work-around ;-)

A simpler workaround is to click on the Lookup button to get a
Dictionary window.

If I'm going to be stuck with that workaound I'd prefer that the
widget didn't waste all that space on the panel for the non-functional
entry area.

Comment 3 Elijah Newren 2004-05-21 15:25:36 EDT
This is a duplicate of bug 108674, bug 108675, and also the upstream
115072 from bugzilla.gnome.org.  It has been fixed.

Note You need to log in before you can comment on or make changes to this bug.