Bug 116223 - im-sdk nvr and source name should include the svn revision
im-sdk nvr and source name should include the svn revision
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Yu Shao
: i18n
Depends On:
Blocks: FC2Update IIIMF
  Show dependency treegraph
 
Reported: 2004-02-19 02:51 EST by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 11.4-46.svn1587
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 22:47:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2004-02-19 02:51:45 EST
Description of problem:
Since we're currently building from the upstream trunk stable
subversion repository, I think it would be better to include
the head revision number in the source tarball and the package
revision number.

Steps to Reproduce:
1. rpm -ql im-sdk-11.4-13.src.rpm | grep bz2
2. rpm -q iiimf-server
  
Actual results:
1. im-sdk-11.4.tar.bz2
2. iiimf-server-11.4-13

Expected results:
1. say im-sdk-11.4.1568.tar.bz2
2. say iiimf-server-11.4.1568-3

Additional info:
It's nice to now when the source is changes,
and this will also make source maintenance easier I think.
Comment 1 Warren Togami 2004-06-10 02:30:57 EDT
I must suggest a slightly different scheme that would be like fedora
Extras package naming policies, and mharris rules.

Version: 1.4
Release: X.svnY
Where X is the incrementing release number of the package, and Y is
the upstream svn revision.

Including the revision number in the Version tag may potentially
clash, necessitating an Epoch increment.  Just hoping to avoid even
the smallest chance.

Target for FC2 Update on June 14th.
Comment 2 Jens Petersen 2004-06-21 21:44:36 EDT
Yu, thanks for changing the tarball filename. :-)

Can we also have the svn revision at least in pkg release
number as Warren suggested?
Comment 3 Jens Petersen 2004-06-23 10:16:46 EDT
Should be fixed in the update for FC2 and in the next devel build.

Note You need to log in before you can comment on or make changes to this bug.