Bug 116250 - printf problems
Summary: printf problems
Status: CLOSED DUPLICATE of bug 118273
Alias: None
Product: Fedora
Classification: Fedora
Component: at-spi   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-19 15:08 UTC by d.binderman
Modified: 2013-04-02 04:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2004-02-19 15:08:52 UTC
Description of problem:

I just tried to compile package at-spi-1.3.7-1

The compiler said

window-listener-test.c(82): warning #268: the format string ends
before this argument

The source code is

  fprintf (stderr, "%s %s\n", event->type, s, t);

Two % specifiers, three trailing parameters. I'm not sure what the fix
is for this.

Suggest add -Wformat to the compiler flags to prevent this kind of
error in future.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Bastien Nocera 2005-02-05 17:11:52 UTC

*** This bug has been marked as a duplicate of 118273 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:01:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.