Bug 118273 - fprintf problems
fprintf problems
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: at-spi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
: 116250 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-14 18:03 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-06 22:28:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes fprintf format string (435 bytes, patch)
2004-07-27 08:59 EDT, Jindrich Novy
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 169453 None None None Never

  None (edit)
Description d.binderman 2004-03-14 18:03:17 EST
Description of problem:

I just tried to compile Fedora Core2 Test1 package at-spi-1.3.7-1

The compiler said

window-listener-test.c(82): warning #268: the format string ends
before this argument

The source code is

  fprintf (stderr, "%s %s\n", event->type, s, t);

Two % specifiers, three trailing parameters.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jindrich Novy 2004-07-27 08:59:04 EDT
Created attachment 102222 [details]
fixes fprintf format string
Comment 2 Bastien Nocera 2005-02-05 12:11:58 EST
*** Bug 116250 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.