Bug 116269 - warning issued from NFS mount
warning issued from NFS mount
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: util-linux (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
: 115003 115606 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-19 11:25 EST by Glen A. Foster
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-23 16:15:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen A. Foster 2004-02-19 11:25:27 EST
Description of problem: after creating an entry in /etc/fstab to set
up an NFS mount, I get the following error with an NFS mount -- the
mount does succeed, but something should change to get rid of the message:

nfs warning: mount version older than kernel

Version-Release number of selected component (if applicable):
# rpm -q kernel util-linux
kernel-2.6.1-1.138.2.1
util-linux-2.12pre-3

How reproducible: very

Steps to Reproduce:
1. perform an NFS mount on RHEL4
Comment 1 Elliot Lee 2004-02-23 16:15:22 EST
It's OK for the message to be there. It's just a warning.
Comment 2 Glen A. Foster 2004-02-23 17:07:12 EST
Strange this is not a bug.  Every other NFS mount warning I've ever
reported was closed FIXED, not NOTABUG.  Are you certain?  Is this the
behavior RHEL4 will exhibit?  If so, we need to document this
somewhere; if not, please consider re-opening this defect and closing
it when an appropriate fix is implemented.
Comment 3 Elliot Lee 2004-02-24 09:55:58 EST
*** Bug 115606 has been marked as a duplicate of this bug. ***
Comment 4 Elliot Lee 2004-02-24 10:35:43 EST
*** Bug 115003 has been marked as a duplicate of this bug. ***
Comment 5 Elliot Lee 2004-02-24 10:41:34 EST
Unfortunately it's the kernel that prints out this message, so I can't
just disable it in /bin/mount. The kernel prints it out when the mount
program isn't as recent as the kernel's NFS mount structure...
According to the source code, this message will go away when we start
using the >= 2.6.2 kernel - /bin/mount just doesn't support the
particular NFS mount structure found in early 2.6.[01] kernels.

Note You need to log in before you can comment on or make changes to this bug.