Bug 116271 - kudzu segfaults
kudzu segfaults
Status: CLOSED DUPLICATE of bug 106332
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-19 11:38 EST by Faye Valentine
Modified: 2014-03-16 22:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Faye Valentine 2004-02-19 11:38:42 EST
My eth0 device is not detected during boot.
Comment 1 Faye Valentine 2004-02-19 11:41:00 EST
Component: redhat-config-network
Version: 1.3.10
Summary: TB6c899893 NCHardwareList.py:318:updateFromKudzu:ImportError:
No module named kudzu
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 163, in main
    window = mainDialog()
  File
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 254, in __init__
  File
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 287, in load
  File
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 299, in loadHardware
  File
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 741, in getHardwareList
  File
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 607, in load
  File
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 445, in updateFromSystem
  File
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 318, in updateFromKudzu
ImportError: No module named kudzu

Local variables in innermost frame:
self: 

__________________________________________________________________
I have a Motorola SB4200 USB cable modem, and I have to reboot my
system four or five times until Fedora Core 1 recognizes it fine and
works fine.
Comment 2 Harald Hoyer 2004-02-20 02:45:10 EST
do you have kudzu installed?
# rpm -V kudzu
Comment 3 Faye Valentine 2004-02-20 15:56:11 EST
Hello, thanks for your answer, I have a standard desktop installation,
 I added the kernel source and the kernel doc, but I haven't
recompiled it.
rpm -V kudzu, doesn't display any message (extracted from "man kudzu":)

       The general form of an rpm verify command is

        rpm {-V|--verify} [select-options] [verify-options]

        Verifying  a  package compares information about the installed
files in
       the package with information about the files  taken  from  the
 package
       metadata  stored  in  the  rpm database.  Among other things,
verifying
       compares the size, MD5 sum, permissions, type, owner and group
of  each
       file.   Any discrepencies are displayed.  Files that were not
installed
       from the package, for example, documentation files excluded on
 instal-
       lation using the "--excludedocs" option, will be silently ignored.

rpm -q kudzu displays

kudzu-1.1.36-1

	I've upgraded to kudzu-1.1.40, with the same problem, so I downgraded
it to kudzu-1.1.36-1
	again: rpm -e kudzu; rpm -ivh kudzu(...) from the CD (md5sum -
correct, linux mediacheck 		- correct).

I've also tried to remove it from the startup services, but my eth0
device wasn't detected, so I've configured it as a service again, and
now is running after configuring local disks (?) (sorry, english is
not my native language... and I don't know if it should be run before
or after configuring the hd(s)). "Probing for new hardware" is
working, not fine, but is working... not at the first boots, but after
several reboots (CTRL+ALT+BACKSPACE) (CTRL+ALT+DEL) works fine, I
don't know why.

kudzu should be installed, shouldn't be?

By the way, Motorola SB4200 USB cable madem emulates an eth device...
Comment 4 Harald Hoyer 2004-02-23 05:00:03 EST
$ ls /usr/lib/python2.3/site-packages/*kudzu*
Comment 5 Faye Valentine 2004-02-23 10:06:19 EST
Thanks Harald
In /usr/lib/python2.3 there's only an empty directory called site-packages

But
ls /usr/lib/python2.2/site-packages/*kudzu*
/usr/lib/python2.2/site-packages/_kudzumodule.so
/usr/lib/python2.2/site-packages/kudzu.py
/usr/lib/python2.2/site-packages/kudzu.pyc
Comment 6 Harald Hoyer 2004-02-23 10:52:15 EST
hmm... which version of python do you use?

$ rpm -q python
Comment 7 Faye Valentine 2004-02-23 17:37:16 EST
rpm -q python

python-2.2.3-7
Comment 8 Harald Hoyer 2004-02-24 04:07:09 EST
please try this:

$ python -c "import kudzu;" && echo OK
Comment 9 Faye Valentine 2004-02-24 19:07:58 EST
I've done it, and OK appeared.
Before, sometimes appear this message at boot time:
Probing for new hardware /etc/rc5.d/S05 kudzu: line 97: 4515
Segmentation fault /usr/sbin/kudzu $KUDZU_ARGS -t 30

Now I get always this message:
Probing for new hardware /etc/rc5.d/S05 kudzu: line 97: 4520
Segmentation fault /usr/sbin/kudzu $KUDZU_ARGS -t 30

I removed kudzu as a service  :(    and I have to reboot several times
before my eth0 is recognized... again.
Comment 10 Harald Hoyer 2004-02-25 04:59:46 EST
Ah!
Segmentation fault /usr/sbin/kudzu
That explains everything :)
Comment 11 Harald Hoyer 2004-02-25 05:00:35 EST

*** This bug has been marked as a duplicate of 106332 ***
Comment 12 Harald Hoyer 2004-02-25 05:01:27 EST
Please try the kudzu-1.1.36.1-1 packages at:
 http://people.redhat.com/notting/kudzu/

These may resolve some of your issues.
Comment 13 Faye Valentine 2004-02-25 18:22:29 EST
Thank you very much Harald, kudzu works fine now, but I had to reboot
three times before my eth0 is recognized, like when I avoid using
kudzu as a service...
Comment 14 Red Hat Bugzilla 2006-02-21 14:01:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.