Bug 116366 - gcc optimizer produces incorrect code
Summary: gcc optimizer produces incorrect code
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 116372 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-20 16:32 UTC by Need Real Name
Modified: 2007-04-18 17:03 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-02-20 16:38:17 UTC


Attachments (Terms of Use)

Description Need Real Name 2004-02-20 16:32:01 UTC
Description of problem:
gcc optimizer option -O2 produces incorrect code

Version-Release number of selected component (if applicable):
gcc-3.2.2-5 [gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)]

How reproducible:
Every time.

Steps to Reproduce:
1.compile and run test program with -O2 option

cat <<EOF > t.c
#include <stdio.h>
#include <string.h>
#include <ctype.h>

int main(int argc, char** argv)
{
    char *str;
    char *s;

    str = strdup("abc");
    s = str;
    printf("str is [%s], s is %c\n", str, *s);
    *s++ = toupper(*s);
    printf("str is [%s], s is %c\n", str, *s);
    free(str);
    return 0;
}
EOF
gcc -o t t.c
./t
gcc -O2 -o t t.c
./t
  
Actual results:
str is [abc], s is a
str is [Bbc], s is b

Expected results:
str is [abc], s is a
str is [Abc], s is b


Additional info:

Comment 1 Jakub Jelinek 2004-02-20 16:38:17 UTC
That's not a bug, your code is broken.
There is no sequence point between s++ on the left side of = operator
and s use on the right side, so the actual result of the operation
is undefined.
See ISO C99 (or earlier standards) for details on sequence points.

Comment 2 Jakub Jelinek 2004-02-20 16:50:31 UTC
*** Bug 116372 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.