Bug 116372 - gcc optimizer produces incorrect code
gcc optimizer produces incorrect code
Status: CLOSED DUPLICATE of bug 116366
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-20 11:49 EST by Need Real Name
Modified: 2007-04-18 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-02-20 11:49:08 EST
Description of problem:
gcc optimizer option -O2 produces incorrect code

Version-Release number of selected component (if applicable):
gcc-3.2.2-5 [gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)]

How reproducible:
Every time.

Steps to Reproduce:
1.compile and run test program with -O2 option

cat <<EOF > t.c
#include <stdio.h>
#include <string.h>
#include <ctype.h>

int main(int argc, char** argv)
{
    char *str;
    char *s;

    str = strdup("abc");
    s = str;
    printf("str is [%s], s is %c\n", str, *s);
    *s++ = toupper(*s);
    printf("str is [%s], s is %c\n", str, *s);
    free(str);
    return 0;
}
EOF
gcc -o t t.c
./t
gcc -O2 -o t t.c
./t
  
Actual results:
str is [abc], s is a
str is [Bbc], s is b

Expected results:
str is [abc], s is a
str is [Abc], s is b


Additional info:
Comment 1 Jakub Jelinek 2004-02-20 11:50:29 EST

*** This bug has been marked as a duplicate of 116366 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:29 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.