Bug 116367 - (PCMCIA)Yenta_socket not being automatically loaded
(PCMCIA)Yenta_socket not being automatically loaded
Status: CLOSED DUPLICATE of bug 121742
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
: 111017 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-02-20 11:38 EST by Brian G. Anderson
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:01:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2004-02-20 11:38:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
I have a Dell Insperion C840.  The "TrueMobile 1150 Series PC Card" is
not detected.

Even when I  manually add "eth1 orinoco_cs" to /etc/modules.conf it
won't work (though it will then appear in the hardware tab for network

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install fc2 test1 on fresh Dell

Actual Results:  Wireless card not detected
Unable to setup manually

Expected Results:  Wireless card automatically detected

Additional info:
Comment 1 Brian G. Anderson 2004-02-23 13:21:22 EST
This cleared up when I updated to the latest development rpms
Comment 2 Brian G. Anderson 2004-02-27 16:26:50 EST
But its back again after upgrading to 2.6.3-1.109
Comment 3 Harald Hoyer 2004-03-01 03:10:32 EST
seems like the kernel?
Comment 4 Bill Nottingham 2004-03-01 22:52:15 EST
Comment 5 Brian G. Anderson 2004-03-02 01:32:48 EST
I've upgraded to 2.6.3-1.116 and I notice that what is happening now
is that the wireless interface on eth1 will come up about 2 out of
three times.  

When it doesn't come up, whenever I do a ifup eth1 it gives me an
error message 'eth1 no such interface'.  Using cardctl to eject and
reinsert the card doesn't clear it. If I reboot, then the wireless
interface will come up.  Next time it occurs I will try and rmmod the
orinico_cs driver first, modprobe orinoco_cs, and see if that brings
the interface back.
Comment 6 Brian G. Anderson 2004-03-15 09:09:08 EST
I see whats going on.  The pcmcia service isn't being started
properly.  When it first boots, pcmcia service says there are no
sockets.  When I manually do a "modprobe yenta_socket" and then do
"service pcmcia restart" then the card appears and then I can start
the wireless card.

Shouldn't yenta_socket be automatically loaded by the init scripts?
Comment 7 Ed Kolis 2004-03-15 15:55:26 EST
I am having much the same problem with Fedora Core 1, except that my 
TrueMobile 1150 is installed in a Latitude C610. What happens to me 
is that when I view the startup details, I see "Error initializing 
eth1; device does not seem to be present [FAILED]". The card does 
show up as a Wavelan on the Internet setup wizard, but when I try to 
go and activate the device, I get a message saying that the driver 
could not be queried or something (sorry, it's been a while since I 
last tried it) and then it stops with the "getting IP information... 
failed" message (even when I have the proper SSID and network key).
Comment 8 Leszek Cieplinski 2004-05-19 08:30:03 EDT
I have the same problem with Dell Latitude CS with PCMCIA Ethernet
card. The workaround from comment 6 works for me.
Comment 9 Alan Cox 2004-05-21 18:10:44 EDT
*** Bug 111017 has been marked as a duplicate of this bug. ***
Comment 10 Eric Herman 2004-05-21 23:50:21 EDT
"yenta_socket be automatically loaded by the init scripts"....

Can you tell me how to edit these scripts so this will load on boot?

I have KDS Valiant 671XH using the TI Yenta Socket. Step #6 also
worked for me, but I would like it to load on boot.
Comment 11 Tor Erik Neuberg 2004-05-23 17:14:43 EDT
Same problem and solution as #6

Hardware: Fujitsu Siemens Amilo D 8820 and Compaq WL100 11 Mbps
Wireless lan card
Comment 12 David Lowe 2004-05-23 17:45:52 EDT
To load at boot time, I adopted the ungraceful solution of adding the
/sbin/modprobe yenta_socket

near the top of the file /etc/rc.d/init.d/pcmcia
Comment 13 Tor Erik Neuberg 2004-05-23 18:06:53 EDT
Nice. Problem solved for me using solution from #12
Comment 14 Tor Erik Neuberg 2004-05-23 18:22:27 EDT
Probably a dub, but it explanes the problem and a more proper solution


Comment 15 Eric Herman 2004-05-24 21:59:18 EDT
Couldn't get it to automatically start when booting up using step #12.

Found bug ID from Comment #14 to be more thorough and the solution
there worked.
Comment 16 Dave Jones 2004-06-18 14:59:19 EDT

*** This bug has been marked as a duplicate of 121742 ***
Comment 17 Red Hat Bugzilla 2006-02-21 14:01:29 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.