Bug 111017 - PCMCIA Fails to recognize Cards
PCMCIA Fails to recognize Cards
Status: CLOSED DUPLICATE of bug 116367
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
: 141706 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2003-11-26 10:22 EST by Chris Tooley
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-05-21 18:25:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Tooley 2003-11-26 10:22:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)

Description of problem:
IBM G40 Thinkpad with Texas Instruments PCI1410 PC card Cardbus
Controller.  Single PCMCIA slot (room for larger cards, but only
single connector).

PCMCIA starts up and gives the warning:
cardmgr[PID#]: Card Services release does not match

Inserting cards does nothing.

Tried a Cisco Aironet 350 (AIR-PCM352), Linksys Prism2 card (have not
installed any third party drivers), and Iomega PCMCIA zip drive.

Tried with rhgb inline and out removed from line.  Tried with acpi=on,
pci=noacpi, acpi=off and combinations of those with rhgb.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Install Fedora Core 1
2.  Boot up
3.  Insert Card

Actual Results:  Nothing happens with card, card not activated

Expected Results:  Card activated and surf internet

Additional info:

Works fine in Red Hat Linux 9 and RHEL 3
Comment 1 Chris Tooley 2003-12-05 08:20:52 EST
The 2.6.0-0.test11 kernel fixes these issues.
Comment 2 Chris Tooley 2004-03-06 11:44:21 EST
With upgrade to Fedora Core 2 Test 1 this has returned. :(
Comment 3 Leszek Cieplinski 2004-05-19 08:45:27 EDT
I have a similar problem on a fresh install of Fedora Core 2 with
a Dell Latitude laptop. The PCMCIA Ethernet card is not visible,
and "service pcmcia start" produces "no sockets found".
Bug 116367 may be a duplicate of this bug; the workaround suggested
there (manual "modprobe yenta_socket") appears to work.
Comment 4 Alan Cox 2004-05-21 18:09:39 EDT
Yes comment #3 is a dup of the 116367 bug
Comment 5 Alan Cox 2004-05-21 18:10:42 EDT

*** This bug has been marked as a duplicate of 116367 ***
Comment 6 Chris Tooley 2004-05-21 18:25:29 EDT
This is just that yenta_socket was not loading.  I had previously
loaded yenta_socket to no avail.

The problem exists due to a BIOS Bug in my IBM laptop.  There may in
fact be a bug that prevented yenta_socket from loading but this is not
that bug.

The April 19, 2004 version of the BIOS for the IBM G40 fixes this problem.
Comment 7 S. Kim Ebert 2004-12-03 19:26:44 EST
*** Bug 141706 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.