Bug 116404 - Login fails and gconfd segfaults
Login fails and gconfd segfaults
Status: CLOSED DUPLICATE of bug 130524
Product: Fedora
Classification: Fedora
Component: GConf (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-20 14:20 EST by aron j darling
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description aron j darling 2004-02-20 14:20:03 EST
I am running a laptop with Fedora core 1 on it.  I used YUM to 
upgrade yesterday and today it will not load my desktop.  The xfree86 
comes up to the login prompt (run level 5) I log in and when the 
screen goes blank to load my personal settings it doesn't load 
anything.  If I use run level 3 and "statrx" from the console x-
window starts up but I only have a mouse X on the screen.  If I ctrl-
alt-backspace to get into the console again, there are no errors?

Feb 20 11:09:27 qaneh gconfd (root-3614): received signal 11, dumping 
core. Please report a GConf bug.
Comment 1 Kjartan Maraas 2004-05-20 09:17:43 EDT
Can you attach gdb to the running gconfd and get a backtrace?

Just run gdb and type 'attach <pid>' where pid is the process id of
gconfd.
Comment 2 Mickey Stein 2004-08-06 21:53:55 EDT
I'm on FC3T1 and getting a signal 11 from gconfd 20 minutes after
Firefox kicks it off (using KDE3). GConf2 version: 2.7.90-1. I
installed debug-info and attached gdb to it. 

Should I start a new bugzilla entry for this? 

This is the backtrace after it segfaults:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 1291)]
0x4014ed03 in g_node_max_height () from /usr/lib/libglib-2.0.so.0
(gdb) bt
#0  0x4014ed03 in g_node_max_height () from /usr/lib/libglib-2.0.so.0
#1  0x4014ed18 in g_node_max_height () from /usr/lib/libglib-2.0.so.0
#2  0x4014f175 in g_node_traverse () from /usr/lib/libglib-2.0.so.0
#3  0x40044773 in gconf_listeners_remove_if (listeners=0x80614f0,
    predicate=0x3, user_data=0x3) at gconf-listeners.c:810
#4  0x0804bd2a in gconf_database_drop_dead_listeners (db=0x3)
    at gconf-database.c:923
#5  0x08051d7d in periodic_cleanup_timeout (data=0x0) at gconfd.c:1017
#6  0x40147078 in g_main_context_wakeup () from /usr/lib/libglib-2.0.so.0
#7  0x401444cb in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#8  0x40145f52 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#9  0x401461ff in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#10 0x08050baf in main (argc=2, argv=0x3) at gconfd.c:869
(


Mickey
Comment 3 Mark McLoughlin 2004-12-20 08:29:45 EST

*** This bug has been marked as a duplicate of 130524 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:01:30 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.