Bug 130524 - gconfd-2 aborts with signal 11 20 - 30 minutes after it starts.
gconfd-2 aborts with signal 11 20 - 30 minutes after it starts.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: GConf2 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
: 116404 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-20 20:17 EDT by Mickey Stein
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 16:16:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mickey Stein 2004-08-20 20:17:15 EDT
Description of problem:

The gconfd-2 component of the GConf2 package (for the last 3 fc2
development tree versions) has segfaulted ~30 minutes after anything
kicks it off. (e.g. Firefox, Any Gnome utility, or gconftool-2
--spawn). I'm using the kde3.3 desktop and all other s/w from the
fc290 dev tree.

Version-Release number of selected component (if applicable):

GConf2-2.7.91.1-1


How reproducible:

Always. Regardless of what invokes gconfd-2, it always goes away after
30 minutes, unless a normal shutdown precedes that time period, in
which case it normally exits (signal 15).


Steps to Reproduce:
1. Start up something built with the gtk2 toolkit, like firefox, or
just use gconftool-2 --spawn to invoke gconfd-2. You'll get the
following (similar, anyway) output.

Aug 20 16:53:59 Kathaldo gconfd (root-8663): starting (version
2.7.91.1), pid 8663 user 'root'
Aug 20 16:53:59 Kathaldo gconfd (root-8663): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only
configuration source at position 0
Aug 20 16:53:59 Kathaldo gconfd (root-8663): Resolved address
"xml:readwrite:/root/.gconf" to a writable configuration source at
position 1
Aug 20 16:53:59 Kathaldo gconfd (root-8663): Resolved address
"xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only
configuration source at position 2

Then 20-30 minutes later without touching the computer (either way):


Aug 20 17:14:59 Kathaldo gconfd (root-8663): Received signal 11,
dumping core. Please report a GConf bug.

2. It'll restart if you use gconftool-2 again. 
3. .. 
  
Actual results:

I'm on FC3T1 and getting a signal 11 from gconfd 20 minutes after
Firefox kicks it off (using KDE3). GConf2 version: 2.7.90-1. I
installed debug-info and attached gdb to it. 

Should I start a new bugzilla entry for this? 

This is the backtrace after it segfaults:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 1291)]
0x4014ed03 in g_node_max_height () from /usr/lib/libglib-2.0.so.0
(gdb) bt
#0  0x4014ed03 in g_node_max_height () from /usr/lib/libglib-2.0.so.0
#1  0x4014ed18 in g_node_max_height () from /usr/lib/libglib-2.0.so.0
#2  0x4014f175 in g_node_traverse () from /usr/lib/libglib-2.0.so.0
#3  0x40044773 in gconf_listeners_remove_if (listeners=0x80614f0,
    predicate=0x3, user_data=0x3) at gconf-listeners.c:810
#4  0x0804bd2a in gconf_database_drop_dead_listeners (db=0x3)
    at gconf-database.c:923
#5  0x08051d7d in periodic_cleanup_timeout (data=0x0) at gconfd.c:1017
#6  0x40147078 in g_main_context_wakeup () from /usr/lib/libglib-2.0.so.0
#7  0x401444cb in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#8  0x40145f52 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#9  0x401461ff in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#10 0x08050baf in main (argc=2, argv=0x3) at gconfd.c:869
(


Mickey


Expected results:

Before downloading the latest 3 versions of GConf2, it would
continually run after being invoked, and only exit when no more
programs that used it were running. It would exit normally (signal 15). 

Additional info:

This is Fedora 2.90 development tree. I use KDE & all the rest if 100%
 up to date as of the date of this bug posting. 

(e.g.) glibc-2.3.3-45
Comment 1 Mark McLoughlin 2004-08-25 16:16:08 EDT
Thanks for the report. Since you have the bug logged upstream, lets
just track it there:

  http://bugzilla.gnome.org/show_bug.cgi?id=150779
Comment 2 Elliott Kipp 2004-11-25 23:41:49 EST
I get the same thing minus the 10 minute wait whenever I start mozilla
nothing happens and in /var/log/messages I get:
Nov 25 23:43:28 testlaptop gconfd (neo-3070): starting (version
2.8.1), pid 3070 user 'neo'
Nov 25 23:43:28 testlaptop gconfd (neo-3070): Received signal 11,
dumping core. Please report a GConf bug.
Comment 3 Mark McLoughlin 2004-12-20 08:29:47 EST
*** Bug 116404 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.