Bug 116482 - requires /usr/bin/kill; should require /bin/kill
requires /usr/bin/kill; should require /bin/kill
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: redhat-lsb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-21 11:42 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-21 13:21:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2004-02-21 11:42:57 EST
Description of problem:
/usr/bin/kill is required but no longer shipped by coreutils. 
utils-linux ships /bin/kill
Comment 1 Gene Czarcinski 2004-02-21 13:21:06 EST
coreutils fixed to add /usr/bin/kill back
Comment 2 Tim Waugh 2004-02-21 18:05:19 EST
See also bug #116100.
Comment 3 Rob Hagopian 2004-03-04 11:07:24 EST
According to the Linux Filesystem Hierarchy Standard
(http://www.pathname.com/fhs/pub/fhs-2.3.html) kill is required to be
in /bin/kill. This would imply that the problem is with redhat-lsb?
(comment also in bug #116100)
Comment 4 Rob Hagopian 2004-03-04 11:09:03 EST
(whoops - forgot to add that coreutils does not include /usr/bin/kill
in coreutils-5.2.0-8.i386.rpm - don't know how that jives w/comment #1
by Gene)
Comment 5 Gene Czarcinski 2004-03-04 11:52:13 EST
OK, this gets complicated and should remain closed ... everything is
now fixed.

The packages in FC2-Test1 had util-linux providing /bin/kill and
coreutils providing /usr/bin/kil and the "current" lsb requiring
/usr/bin/kill.

The util-linux-2.12-4 and the latest coreutils fixes things.  First,
/usr/bin/kill was removed from coreutils.  Then, util-linux-2.12-4 has
been changed to provide /bin/kill (it was doing that already) and a
sym-link: /usr/bin/kill->/bin/kill

These packages must be installed together so that redhat-lsb does not
get upset (must be installed --oldpackage for other reasons).

So the system not has both /bin/kill and /usr/bin/kill and the
redhat-lsb-1.3 is OK and a future lsb that moves the requirement to
/bin/kill

Note You need to log in before you can comment on or make changes to this bug.