Bug 116537 - sata not detected during install
sata not detected during install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks: FC2Blocker 117712 118881
  Show dependency treegraph
 
Reported: 2004-02-22 19:52 EST by Marshall Lewis
Modified: 2013-07-02 22:18 EDT (History)
4 users (show)

See Also:
Fixed In Version: FC2T3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-28 11:20:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marshall Lewis 2004-02-22 19:52:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
Once the actual install process begins, the sata driver isn't loaded,
and when forced to load (extract from modules.cgz and insmod libata.ko
+ (in my case) sata_via.ko) and after creating the devices (mknod
/dev/hde[1-12]) it still doesn't show in disk druid (maybe something
else I need to update?).

The interesting part (to me) is.. that if I boot from the boot.iso,
and select hard disk install.. it sees hde at that point.. but once I
begin the install, it goes away.

Version-Release number of selected component (if applicable):
probably anaconda-9.91-0.20040212195024

How reproducible:
Always

Steps to Reproduce:
1. attempt install to sata drive


Actual Results:  doesn't load the driver, doesn't see the drive

Expected Results:  load the driver, see the drive

Additional info:
Comment 1 Jeremy Katz 2004-02-23 18:35:05 EST
Could you attach lspci -vn output?  And this is devel and not fc1
test, correct?
Comment 2 Marshall Lewis 2004-02-23 20:44:52 EST
Yes, this is devel

lspci from my (kinda) working install follows:

0000:00:00.0 Class 0600: 1106:3188 (rev 01)
        Subsystem: 1462:1300
        Flags: bus master, 66Mhz, medium devsel, latency 8
        Memory at f0000000 (32-bit, prefetchable)
        Capabilities: [80] AGP version 3.0
        Capabilities: [c0] #08 [0060]
        Capabilities: [68] Power Management version 2
        Capabilities: [58] #08 [8001]
 
0000:00:01.0 Class 0604: 1106:b188
        Flags: bus master, 66Mhz, medium devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 0000a000-0000afff
        Memory behind bridge: f8000000-f9ffffff
        Prefetchable memory behind bridge: d0000000-efffffff
        Expansion ROM at 0000a000 [disabled] [size=4K]
        Capabilities: [80] Power Management version 2
 
0000:00:05.0 Class 0100: 9005:0010
        Subsystem: 9005:a180
        Flags: bus master, medium devsel, latency 32, IRQ 16
        BIST result: 00
        I/O ports at b000
        Memory at fb014000 (64-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 1
 
0000:00:06.0 Class 0401: 1102:0004 (rev 04)
        Subsystem: 1102:1007
        Flags: bus master, medium devsel, latency 32, IRQ 17
        I/O ports at b400
        Capabilities: [dc] Power Management version 2
 
0000:00:06.1 Class 0980: 1102:7003 (rev 04)
        Subsystem: 1102:0060
        Flags: bus master, medium devsel, latency 32
        I/O ports at b800
        Capabilities: [dc] Power Management version 2
 
0000:00:06.2 Class 0c00: 1102:4001 (rev 04) (prog-if 10)
        Subsystem: 1102:0010
        Flags: bus master, medium devsel, latency 32, IRQ 18
        Memory at fb015000 (32-bit, non-prefetchable)
        Memory at fb010000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [44] Power Management version 2
 
0000:00:0b.0 Class 0200: 14e4:1653 (rev 03)
        Subsystem: 1462:1300
        Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 16
        Memory at fb000000 (64-bit, non-prefetchable)
        Capabilities: [48] Power Management version 2
        Capabilities: [50] Vital Product Data
        Capabilities: [58] Message Signalled Interrupts: 64bit+
Queue=0/3 Enable-
 
0000:00:0f.0 Class 0104: 1106:3149 (rev 80)
        Subsystem: 1462:1300
        Flags: bus master, medium devsel, latency 32, IRQ 20
        I/O ports at bc00
        I/O ports at c000 [size=4]
        I/O ports at c400 [size=8]
        I/O ports at c800 [size=4]
        I/O ports at cc00 [size=16]
        I/O ports at d000 [size=256]
        Capabilities: [c0] Power Management version 2
 
0000:00:0f.1 Class 0101: 1106:0571 (rev 06) (prog-if 8a [Master SecP
PriP])
        Subsystem: 1462:1300
        Flags: bus master, medium devsel, latency 32, IRQ 20
        I/O ports at d400 [size=16]
        Capabilities: [c0] Power Management version 2
 
0000:00:10.0 Class 0c03: 1106:3038 (rev 81)
        Subsystem: 1462:1300
        Flags: bus master, medium devsel, latency 32, IRQ 21
        I/O ports at d800 [size=32]
        Capabilities: [80] Power Management version 2
 
0000:00:10.1 Class 0c03: 1106:3038 (rev 81)
        Subsystem: 1462:1300
        Flags: bus master, medium devsel, latency 32, IRQ 21
        I/O ports at dc00 [size=32]
        Capabilities: [80] Power Management version 2
 
0000:00:10.2 Class 0c03: 1106:3038 (rev 81)
        Subsystem: 1462:1300
        Flags: bus master, medium devsel, latency 32, IRQ 21
        I/O ports at e000 [size=32]
        Capabilities: [80] Power Management version 2
 
0000:00:10.4 Class 0c03: 1106:3104 (rev 86) (prog-if 20)
        Subsystem: 1462:1300
        Flags: bus master, medium devsel, latency 32, IRQ 21
        Memory at fb016000 (32-bit, non-prefetchable)
        Capabilities: [80] Power Management version 2
 
0000:00:11.0 Class 0601: 1106:3227
        Subsystem: 1462:1300
        Flags: bus master, stepping, medium devsel, latency 0
        Capabilities: [c0] Power Management version 2
 
0000:00:18.0 Class 0600: 1022:1100
        Flags: fast devsel
        Capabilities: [80] #08 [2101]
        Capabilities: [a0] #08 [2101]
        Capabilities: [c0] #08 [2101]
 
0000:00:18.1 Class 0600: 1022:1101
        Flags: fast devsel
 
0000:00:18.2 Class 0600: 1022:1102
        Flags: fast devsel
 
0000:00:18.3 Class 0600: 1022:1103
        Flags: fast devsel
 
0000:01:00.0 Class 0300: 1002:4152
        Subsystem: 1043:c002
        Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 16
        Memory at d0000000 (32-bit, prefetchable)
        I/O ports at a000 [size=256]
        Memory at f9000000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [58] AGP version 3.0
        Capabilities: [50] Power Management version 2
 
0000:01:00.1 Class 0380: 1002:4172
        Subsystem: 1043:c003
        Flags: 66Mhz, medium devsel
        Memory at e0000000 (32-bit, prefetchable) [disabled]
        Memory at f9010000 (32-bit, non-prefetchable) [disabled]
[size=64K]
        Capabilities: [50] Power Management version 2


If it makes a difference I can try and run it from the installer later
tonight.

Not sure if this matters, but I'm having to boot using acpi=off else I
get weird timeouts on the sata drive.

And, just because : )  I noticed tonight, that I can't install using a
usb keyboard, once the installer begins, my keyboard stops working. 
(I was using a ps/2 adapter before).
Comment 3 Pekka Pietikäinen 2004-03-04 11:24:17 EST
Isn't this a general hwdata issue, the libata drivers don't seem to be
listed at all. Or am I missing something? :-)
Comment 4 Bill Nottingham 2004-03-11 11:23:59 EST
It's in modules.pcimap, so it should work. Is it in module-info?
Comment 5 Pekka Pietikäinen 2004-03-11 11:34:26 EST
I think this is explained by modules.pcitable being empty lately
(snapshot from 03-06) I checked yesterdays snapshot and it looks sane
now, so this bug might even be fixed. Will check later tonight.

I saw this same problem on a x86 (promise sata), an additional problem
to autoloading not working was that manual installation didn't work
either, the only option given was a driver disk. In test1 the module
could be loaded manually just fine.
Comment 6 Jeremy Katz 2004-03-11 15:09:06 EST
Yes, this should be fixed by current rawhide since modules.pcimap now
gets generated correctly.
Comment 7 Pekka Pietikäinen 2004-03-11 17:48:02 EST
Works for me now, hopefully for the original reporter as well.
Comment 8 Marshall Lewis 2004-03-11 21:55:40 EST
Close, but now while it loads the sata_via module, it doesn't create
the /dev/hde* devices   .. I just tested this using the boot.iso image
dated today (the 11th) and using ftp install from the duke mirror. 
Just in case it's relevent, I also have an adaptec scsi controller
installed, and it did pick that up and created the /dev/sd* devices.


Comment 9 Pekka Pietikäinen 2004-03-12 01:36:42 EST
Err... Unless something is completely different with sata_via, the
drive should be showing up as a SCSI one (i.e. /dev/sd* ). Check the
boot logs from virtual console 3 :-)
Comment 10 Marshall Lewis 2004-03-12 06:54:30 EST
No, it comes up as /dev/hde and /dev/hdf (if I had a 2nd drive).. I
can go to the console and mknod /dev/hde and fdisk -l it to see my
existing partitions.  sata_via has been coming up as /dev/hde for a
bit over a month now.. can't remember exactly when it changed....
maybe it was with the 2.6 kernel?  I thought it was something they'd
changed for all the sata controllers, but maybe not, and I only have
one I can test : )

Comment 11 Marshall Lewis 2004-03-18 07:45:04 EST
I guess I was supposed to change the status on this... I had retested,
and it was still broken (modules loads automatically now, but the
devices don't get created).
Comment 12 Jeremy Katz 2004-03-22 14:16:29 EST
I think this is due to the legacy VIA IDE driver not masking SATA
ports to be used by the SATA driver instead.
Comment 13 Marshall Lewis 2004-04-28 11:20:47 EDT
Just tested with the FC2T3 install iso's and it works correctly..
Thanks to whoever fixed this : )  Let me know if you have any
questions, but I'd say this bug can be marked as resolved now. (Guess
I'll do that.)

Note You need to log in before you can comment on or make changes to this bug.