This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 118881 - Harddrive install fails since anaconda ignores source drive
Harddrive install fails since anaconda ignores source drive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 119349 119468 119481 119926 119939 120114 (view as bug list)
Depends On: 116537
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-22 04:42 EST by Pekka Pietikäinen
Modified: 2007-11-30 17:10 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-28 11:33:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg and lspci output (2.60 KB, text/plain)
2004-03-31 14:42 EST, Ron Yorston
no flags Details

  None (edit)
Description Pekka Pietikäinen 2004-03-22 04:42:07 EST
Description of problem:

When trying to do a harddrive install, from a dvd-sized .iso on a sata
drive (sata_promise so should be /dev/sda3), boot.iso (from the 19th)
the installer doesn't find any drives to install from, just 
offers the option of using a driver disk. The correct modules
do get loaded (now that modules.pcimap is ok)

When looking at the debug messages, the installer does
"see" them, but marks them as ignore. The messages in question were
something like 

hda: "WDC WD1200JB-00EVA0" ... ignore ... (the drive I want to install
to, consists of an totally unconfigured partition of type Linux LVM)
sda: "Maxtor 6Y120M0" ... ignore ... (the drive I want to install from)

(hopefully enough for you to figure out what I'm talking about, 
I can write down the exact messages if necessary)

Could be related to #116537, it's hard to know whether
it's a matter of device nodes getting created or not since there's no
shell, so I filed this as a separate bug and added a dependancy instead.
Comment 1 Jeremy Katz 2004-03-22 14:06:13 EST
Fixed in CVS
Comment 2 Pekka Pietikäinen 2004-03-27 18:16:44 EST
Didn't seem to work with boot.iso from the 26th...
Comment 3 Bill Nottingham 2004-03-29 18:23:31 EST
New anaconda hasn't been pushed since then.
Comment 4 Bill Nottingham 2004-03-29 18:25:02 EST
*** Bug 119349 has been marked as a duplicate of this bug. ***
Comment 5 graham voysey 2004-03-30 01:52:36 EST
Bug has been dupicated on a sony laptop, model pcg-tra2 with an ide
fujitsu harddrive.  using the boot images provided in (the md5sum
verified) FC2-test2-binary-i386-disc1.iso 's /isolinux directory,
(downloaded from duke university LUG on 29 March 2004 16:00h EST) and
attempting a harddrive installation.  Selection of harddrive-install
method caused anaconda to prompt for drivers for the harddrive (none
of which work).  anaconda was booted with and without the askmethod
option, as well as with and without hda=ide as a parameter, with no joy.

debug logs of anaconda indicate that the harddrive is being found
successfully, then flagged as ignored.

bug priority marked high because it prevents booting.  Anectodal
evidence of similar failures for attempted CD and Network installs is
common on fedora-devel mailing list.
Comment 6 Toms Baugis 2004-03-30 07:04:01 EST
i have the same situation as in comment #5 (anaconda brutally ignores
my hard drive (maxtor 80GB something)

is there a workaround for this?
Comment 7 Jaak Simm 2004-03-30 15:07:45 EST
Same here, using boot.img of FC2-test2 the boot section ignores my ATA
Maxtor 80GB (6Y080P0). And when choosing hard-drive install, it claims
no disks found. Hard-drive installation reports the following line to
the ALT-F3 console:

 devices[0] is Maxtor 6Y080P0 - hda using ignore (not loaded)

If a new boot.iso is available addressing the problem, please notify
this list.
Comment 8 Bill Nottingham 2004-03-30 16:56:17 EST
*** Bug 119468 has been marked as a duplicate of this bug. ***
Comment 9 Bill Nottingham 2004-03-30 17:19:04 EST
*** Bug 119481 has been marked as a duplicate of this bug. ***
Comment 10 John Mellor 2004-03-30 19:37:19 EST
This is new breakage with FC2t2.  CD boot fails using an Acer 32x
CDrom drive, almost instantaneously, like someone removed a critical
drive-ready timed wait.

I worked around it by inserting the first FC2t1 CD, and switching it
to the correct FC2t2 first CD at the first prompt (hit enter to
proceed with install).  After that, it works properly.
Comment 11 graham voysey 2004-03-30 19:57:10 EST
note that the method proposed in comment 10 does not function for
hard-drive installations.  Using the boot.img provided by FC2-test1
returns an error that the iso's don't match and the installation can't
proceed.  The effectiveness of the proposed method is unknown for
other install types (ftp, nfs, etc.)
Comment 12 Ron Yorston 2004-03-31 14:41:02 EST
Since I couldn't get my FC2T2 CD to boot I copied the kernel and
initrd from the CD onto my hard disk and booted using GRUB.  Wouldn't
you know it, I now find that anaconda doesn't see my hard disks.  I
have two IDE controllers:  one on my GA-7VAX motherboard and one PCI.
 The first HDD and CD are on the motherboard controller the second
hard disk on the PCI controller.  
Comment 13 Ron Yorston 2004-03-31 14:42:15 EST
Created attachment 99014 [details]
dmesg and lspci output
Comment 14 Jared Smith 2004-04-02 17:06:41 EST
I'm seeing the same thing... is this bug a duplicate of bug #118941 by
chance?  Or are they somehow related?
Comment 15 Jeremy Katz 2004-04-05 18:23:37 EDT
*** Bug 119939 has been marked as a duplicate of this bug. ***
Comment 16 Jeremy Katz 2004-04-06 14:34:30 EDT
*** Bug 120114 has been marked as a duplicate of this bug. ***
Comment 17 Need Real Name 2004-04-09 14:28:11 EDT
I can confirm this on nForce 2 based board (Abit NF7-S 2.0). Drives
are ignored! Doing 'linux expert' and supplying drvblock.img from the
floppy does not work as it contains same drivers as the boot.iso
Comment 18 Noa Resare 2004-04-09 15:37:27 EDT
I also had this problem when trying the pxeboot kernel/initrd from
fc2test2 however the ones available in the current development tree
(dated 040408) correctly detects my hard disk:

8e8e54ac9eecb1b3f5380d24010b34ce  initrd.img
4f071cadde7e78ae622522898e9e29c3  vmlinuz

My conclusion from this is that it is safe to close this bug as FIXED

(of course the installer barfs on the *iso files contained on the disk
that it just detected, complaining about a version mismatch, so I'm
off wasting blank CD-R's anyway)
Comment 19 Need Real Name 2004-04-09 16:33:56 EDT
Yes, boot.iso in devel tree has been updated and it does detect the
drives correctly, however multimedia mismatch will prevent anyone from
installing FC2T2. 

Are you saying replacing initrd and vmlinuz inside the iso will work?
Comment 20 Jeremy Katz 2004-04-11 13:23:56 EDT
*** Bug 119926 has been marked as a duplicate of this bug. ***
Comment 21 Need Real Name 2004-04-11 14:31:52 EDT
How do you build a working boot.iso so it recognizes 1.91 media?
Comment 22 Noa Resare 2004-04-11 14:50:59 EDT
I don't know, I didn't. I think fc2test2 is only installable with the
whole distribution on cdrom or over the network.

Of course it is possible to backport the fix to anaconda that makes it
detect the hard drives to the original fc2test2 bootdisk binaries but
that seems like lots of work that´s not leading anywhere to me.
Comment 23 Pekka Pietikäinen 2004-04-28 11:33:59 EDT
Fixed in test3.

Note You need to log in before you can comment on or make changes to this bug.