Bug 116571 - chown does not allow dotted notation
Summary: chown does not allow dotted notation
Status: CLOSED DUPLICATE of bug 116536
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: coreutils (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-23 11:22 UTC by Felipe Alfaro Solana
Modified: 2007-04-18 17:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Felipe Alfaro Solana 2004-02-23 11:22:42 UTC
Description of problem:
Starting with coreutils 5.2.0-4, /bin/chown does not allow simple
dotted user.group notation as previous versions did. It seems that
only the colon user:group notation is allowed:

# /bin/chown rpm.rpm /tmp/whatever
/bin/chown: `rpm.rpm': invalid user

Also, when upgrading the rpm package, a similar error is shown as it
seems the post script invokes /bin/chown rpm.rpm on some files.

Version-Release number of selected component (if applicable):
5.2.0-4

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to coreutils-5.2.0-4
  
Actual results:
/bin/chown doesn't allow for user.group dotted notation.

Expected results:
/bin/chown should allow for user.group dotted notation as previous
versions did.

Additional info:

Comment 1 Tim Waugh 2004-02-23 11:52:01 UTC

*** This bug has been marked as a duplicate of 116536 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:01:32 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.