Bug 116536 - (chown-period) chown doesn't take user.group syntax
chown doesn't take user.group syntax
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 116571 116632 116690 116694 116695 116696 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-22 18:51 EST by Chris Adams
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version: 5.2.0-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-24 04:35:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2004-02-22 18:51:28 EST
"chown user.group file" doesn't work; only "user:group" (colon instead
of period) works.  I don't know if this change is intentional or if it
is there just because the upstream default changed.

If the change is permanent, then there should definately be something
in the the release notes about this.  There are numerous RPMs
(utempter and at to name a couple I noticed) that use "chown
user.group" syntax in scriptlets like %post.  Also, IIRC the reason
for not allowing "." in user/group names was because of chown, so if
the change is permanent, that restriction should be removed.

Filed against devel because I noticed it while updating FC2 test1 to
development tree (so I don't know if it was in test1).
Comment 1 Tim Waugh 2004-02-23 06:52:03 EST
*** Bug 116571 has been marked as a duplicate of this bug. ***
Comment 2 Tim Waugh 2004-02-23 07:02:22 EST
See the documentation:

--
Some older scripts may still use `.' in place of the `:' separator.
POSIX 1003.1-2001 (*note Standards conformance::) does not allow that,
but you may be able to work around the compatibility problems by setting
`_POSIX2_VERSION=199209' in your environment.  New scripts should avoid
the use of `.' because GNU `chown' may fail if OWNER contains `.'
characters.
--

The colon separator has been the recommended syntax for many releases.
 Time to fix instances of the old syntax so we can move on.

One reason for this, aside from POSIX, is the possibility of having
user account names containing '.', currently not allowed.  It would be
great to remove this restriction.

Yes, it needs to be mentioned in the release notes.

I'll keep this bug report open for a while, until the packages whose
scriptlets still use '.' as separator have been rebuilt.  I have fixed
as many as I could find in CVS.
Comment 3 Tim Waugh 2004-02-23 12:20:50 EST
Update: it turns out that LSB requires chown to accept '.' still. :-(

Message sent to bug-coreutils to see if this behaviour is permanent.
Comment 4 Bill Nottingham 2004-02-23 18:51:17 EST
*** Bug 116632 has been marked as a duplicate of this bug. ***
Comment 5 Tim Waugh 2004-02-24 04:09:21 EST
Looks like this has been reverted in upstream coreutils.
Comment 6 Bill Nottingham 2004-02-24 12:17:18 EST
*** Bug 116690 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2004-02-24 15:24:49 EST
*** Bug 116694 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2004-02-24 15:24:55 EST
*** Bug 116695 has been marked as a duplicate of this bug. ***
Comment 9 Bill Nottingham 2004-02-24 15:25:00 EST
*** Bug 116696 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.