Bug 116634 - Evolution hyperlink problems
Evolution hyperlink problems
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 115862 116633 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-23 18:04 EST by Scott Sloan
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 22:28:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Sloan 2004-02-23 18:04:20 EST
Description of problem:

Evolution has various problems when you recieve an email containing
hyper links.

First problem can be found when you click on the link, no browser is
opened to view the link enough a default browers is set in gnome. 

Second problem can be found when you right click on a link and select
copy link location. The location does get sent to the "clipboard" to
be pasted in the browser.

Version-Release number of selected component (if applicable):

1.5.3

How reproducible:

always


Steps to Reproduce:
1. Open evolution
2. Open email with links
3. read above
  
Actual results:

Nothing happens

Expected results:

To open or copy the link location

Additional info:
Comment 1 Scott Sloan 2004-02-23 18:05:19 EST
*** Bug 116633 has been marked as a duplicate of this bug. ***
Comment 2 Scott Sloan 2004-02-23 18:06:01 EST
*** Bug 115862 has been marked as a duplicate of this bug. ***
Comment 3 Scott Sloan 2004-03-08 01:39:08 EST
This is still a problem in 1.5.5
Comment 4 Scott Sloan 2004-03-08 18:10:24 EST
This is not a bug in evolution but rather a problem with
control-center and perferred applications not properly storing the
values. I found this out by install epiphany and reproducing this bug.
Both Mozilla 1.6 and Epiphany 1.1 are now installed on the system.
When I go to control-center -> preferred applications and chose
epiphany as my default browers, and then go to evolution and click on
a link the problem is not there. But when I change the default browers
to mozilla, and click on a link in evolution, nothing happens. For
some reason perferred applications isn't recording the browser change.
The same thing happens when you try and change the default email client.


Steps to reproduce
1.) Open control panel
2.) open preferred applications
3.) select mozilla as default browser
4.) open evolution
5.) open email with link, click on link.... nothing happens
6.) open preferred applications
7.) select epiphany as default browser
8.) click on link in email in evolution... link opens


links should open in whatever browers the user picks. Somewhere
preferred apps. is only recording gnome specific apps.  
Comment 5 Sarantis Paskalis 2004-03-14 14:19:46 EST
The problem exists for all hyperlinks.  In the prefered applications
window, the mozilla fails because the string to be executed is
"mozilla-1.6 %s".

If I change it manually to "mozilla %s", the link opens ok in mozilla.

Running rawhide and control-center-2.5.4-1
Comment 6 Per Bjornsson 2004-04-08 22:17:00 EDT
On a fresh installation of TC2t2 updated to rawhide, links still
didn't work for me until I went into the preferred applications config
and chose mozilla. Once I choose Mozilla there it works. Where is the
default set before the user puts it in? It would be preferable if the
systemwide defaults actually worked...
Rawhide as of 4/7/2004, control-center-2.6.0.3-1.
Comment 7 Scott Sloan 2004-04-08 22:28:47 EDT
This also works using evolution 1.5-5 against the new control panel.
However for some reason control-panel defaults to epiphany even if
epiphany isn't installed. I'm going to close this and file a new bug
for that. 

Note You need to log in before you can comment on or make changes to this bug.