Bug 116642 - CIFS filesystem attempts to mount before networking
CIFS filesystem attempts to mount before networking
Status: CLOSED DUPLICATE of bug 115691
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-23 23:14 EST by Erich Hoover
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Erich Hoover 2004-02-23 23:14:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
When the system is booting CIFS filesystem mounts in /etc/fstab are
treated as local filesystems instead of remote systems (apparently),
so the system tries to mount the remote CIFS system before the network
driver loads (and reverse on shutdown).

Version-Release number of selected component (if applicable):
kernel-2.6.3-1.97

How reproducible:
Always

Steps to Reproduce:
1. Create a CIFS mount in /etc/fstab
2. Reboot the computer
3. If you're in text mode you'll see it right away, if you're in
graphical the step is hidden from the "details" view so you'll have to
look at /var/log/messages to see the error
    

Actual Results:  The CIFS filesystem attempts to mount before the
network driver loads and actually does mount after the network driver
loads.  On shutdown it appears to attempt to unmount after the network
driver unloads.

Expected Results:  The network driver should load first and then the
CIFS should mount, on shutdown the CIFS mount should unmount first
then the network driver should unload.

Additional info:

Data from /var/log/messages:

...
Feb 22 13:24:54 FEDORA kernel: EXT3 FS on hda2, internal journal
Feb 22 13:24:54 FEDORA kernel: EXT3-fs: mounted filesystem with
ordered data mode.
Feb 22 13:24:54 FEDORA kernel:  CIFS VFS: Error connecting to IPv4
socket. Aborting operation
Feb 22 13:24:54 FEDORA kernel:  CIFS VFS: cifs_mount failed w/return
code = -101
...
Feb 22 13:24:54 FEDORA kernel: 8139too Fast Ethernet driver 0.9.27
Feb 22 13:24:54 FEDORA kernel: eth0: RealTek RTL8139 at 0xe086c000,
00:e0:7d:d1:22:6e, IRQ 12
Feb 22 13:24:54 FEDORA kernel: kudzu: numerical sysctl 1 49 is obsolete.
Feb 22 13:24:54 FEDORA kernel: ip_tables: (C) 2000-2002 Netfilter core
team
Feb 22 13:24:54 FEDORA kernel: ip_tables: (C) 2000-2002 Netfilter core
team
Feb 22 13:24:54 FEDORA kernel: eth0: link up, 100Mbps, full-duplex,
lpa 0x41E1
Feb 22 13:24:52 FEDORA network: Bringing up interface eth0:  succeeded 
Feb 22 13:24:57 FEDORA netfs: Mounting other filesystems:  succeeded
...
Comment 1 Bill Nottingham 2004-02-24 01:48:31 EST

*** This bug has been marked as a duplicate of 115691 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:35 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.