Bug 116653 - after upgrade to FC2-test1 on dual boot sys => MSwinXP is unbootable
after upgrade to FC2-test1 on dual boot sys => MSwinXP is unbootable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
: 116501 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-02-24 03:19 EST by andrej
Modified: 2007-11-30 17:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 11:52:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fdisk and parted info from FC1 (2.68 KB, text/plain)
2004-04-13 13:48 EDT, Gene Czarcinski
no flags Details
info from Fc2T2 (6.17 KB, text/plain)
2004-04-13 13:50 EDT, Gene Czarcinski
no flags Details
Output from commands on FC2T3 (1.62 KB, text/plain)
2004-05-17 20:21 EDT, Anthony DeStefano
no flags Details

  None (edit)
Description andrej 2004-02-24 03:19:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
I'm sorry - but I have filed this bug under anaconda simply because I
don't know wether it's a problem of the kernel, anaconda, parted ...
or what else

...anyway, I have(had) a dual boot system (MSwinXP) and
Fedora(FC1stable); I upgraded to FC2-test1; FC2-test1 boots&runs now
without major problems really - while winXP resulted now as being
unbootable - while trying to boot I have a message saying  a vital
.dll cannot be found. 

- transferring my HDD (a 80GB IDE Seagate, no precise data on model at
the moment) to another winXP-only PC, I tried to check the partition
table with with "partition magic 8.0" - and right at the beginning I
can see that program giving out a warning message about errors in the
partition table (CHS and LBA values reportedly don't match); PM8.0
suggests LBA values are the correct ones.

-anyway, the only way I managed to get (temporarily) the thing to work
right (to boot winXP again) was to copy the content of the active NTFS
partition from my HDD to the other PC's HDD; remove all the partitions
from my HDD; produce a brand-new partition table on it, with a new
NTFS partition marked as active; copy my winXP OS files back to this
partition

...in this way (and with the help of of a winXP boot disk) I managed
to get winXP again up&running

...but as a proof there's more intelligence on Mars that in my
head...I tried again to install FC2-test1...and got basically the same
result again...winXP won't boot - a check with "Partition magic" gives
the same result again. 

- if I'm not mistaken, on the first installation "parted" gived out a
warning there was something wrong with the partition table (some kind
of problem it said it should be fixable); subsequently parted gives
out no  warning whatsoever.









Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install FC2-test1 on a (MSWinXP) dual boot sys
2.try to boot into winXP
3.
    

Actual Results:  winXP won't boot

Additional info:
Comment 1 Erich Hoover 2004-02-29 15:14:38 EST
I upgraded from FC1 to the FC2 test and I have no problems accessing
my existing WinXP partition.  You should try running some of MS' MBR
check tools if parted gives a partition table warning, they're under
the console recovery option.
Comment 2 andrej 2004-03-01 14:24:29 EST
Many thanks indeed, Erich!

you suggestion under #1 did the job; now I have a dual-boot machine
again...

-I'm glad you had no problems whatsoever; however, perhaps it would be
nice to include some words of such a troubleshooting procedure in the
release notes?! - just in case some other user experiences the same
problem (...two times in a row...) 
 ...or perhaps I must suppose the test-forum is the place to do that...
Comment 3 Erich Hoover 2004-03-01 14:50:48 EST
Personally, I think that parted should provide more details about the
error and a required "do this to fix it and run parted again". 
Especially with disk problems I feel that it is important to not allow
the user to proceed when the operation might damage the system.
Comment 4 Jeremy Katz 2004-04-12 23:40:28 EDT
*** Bug 116501 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2004-04-12 23:46:55 EDT
Could people who have experienced difficulty with dual-booting between
their FC2 test2 installs and a Windows install of some sort get as
much as possible of the following information for me?  

1) The geometry as reported by parted (if you can get from an old FC1
install and an FC2, that would really rule)
2) modprobe edd and then get the values from all of the files in
/sys/firmware/edd/int13_dev80
3) The output of 'geometry (hd0)' from a grub prompt in a running 2.6
kernel
4) The output of 'geometry (hd0)' from a grub prompt when booting from
the BIOS
Comment 6 Gene Czarcinski 2004-04-13 13:47:26 EDT
I thought there would be more response.  Anyway, I am attaching the
results I got from running parted, etc. on FC1 and FC2T2 (kernel-smp
2.6.5-1.319).

I am include info on both hda and hdb since they are identical Maxtor
60GB drives.

I am attaching rather than pasting inline because the text is a bit
lengthy.
Comment 7 Gene Czarcinski 2004-04-13 13:48:22 EDT
Created attachment 99368 [details]
fdisk and parted info from FC1
Comment 8 Gene Czarcinski 2004-04-13 13:50:04 EDT
Created attachment 99369 [details]
info from Fc2T2

This includes fdisk, parted, grub under 2.6 kernel and edd info.  In addition,
I have added the info I saw from running grub under the bios (which is
different that grub under 2.6 kernel
Comment 9 Jeremy Katz 2004-04-15 01:02:50 EDT
This should be better with test3.  grub had some geometry handling and
I've fixed it up to read from the partition table as well as fixing
the one case where parted would slip up still
Comment 10 Johan Bondeson 2004-04-15 16:35:33 EDT
May I ask a question?
My machine is set up as a dual-boot with windows on /dev/hda and FC2
on /dev/hdb. hda uses the windows-compatible geometry and hdb uses the
geometry set during FC2 install. The problem is Grub is a bit kinky
about this. I have to use WinXPs native ntloader to boot win and grub
on a boot disk to boot FC2, cause grub can't handle two diffrent
geometrys at the same time, it seems.
First question: Is there a way to make grub handle this?
Second question: If there is'nt, can I change the geometry on hdb
without destroying my FC2 installation?
Comment 11 Jason Montleon 2004-04-23 15:31:04 EDT
I have an IBM T30 with Windows XP installed on /dev/hda1 with 
Partition Magic 8.01, Fedora Core 1 on /dev/hda2 with a swap 
partition on /dev/hda3.  Fedora Core 2 Test 2 was installed and yum 
update'd to Test 3 on /dev/hda4, again using /dev/hda3 as its swap.

I have the Windows XP boot loader installed in the MBR, FC1 has grub 
loaded on /dev/hda2 with LBA enabled, and FC2 has grub loaded 
on /dev/hda4 with LBA enabled.

I then ran from Windows XP:
bootpart 2 LBA c:\linux.bin "Fedora Core 1"
bootpart 4 LBA  c:\linuxtest.bin "Fedora Core 2"

which makes it possible for me to chain load grub from the 
appropriate linux partition and boot into whichever that version of 
Fedora Core.  I have not had any problems, per se but every time I 
enter Partition Magic I am getting the error message:
http://www.montleon.com/pm1.png

If I click no it continues, if I click yes I get these:
http://www.montleon.com/pm2.png
http://www.montleon.com/pm3.png

And from then on when I start PM8 I get this messages:
http://www.montleon.com/pm4.png


These occur whether I create and format the partition with PM8 (but 
only after installing FC2), or I create it via Disk Druid and FC2 and 
format it during install.  I've managed to do some really bad stuff 
with selinux that have made it easier to reload about 4 times over 
now, and each time I delete and recreate the partition PM8 stops 
complaining reinstall FC2.  Interestingly enough from its perspective 
the partition is also full (http://www.montleon.com/pm5.png) from the 
time I reboot from installing FC2 on, even though when I reboot and 
log into FC2 and look it's more like 51% full., and I cannot access 
it with the tool that also comes with PM8.

This is what it should and does look like for FC1:
http://www.montleon.com/pm6.png
and for FC2:
http://www.montleon.com/pm7.png

I have no idea how much of this is in any way related to what you are 
looking at, or if it is a totally separate issue perhaps to do with 
PM8 rather than FC2, but it has definately struck me as unusual, but 
either way I hope you find this information useful:

'/sbin/parted /dev/hda print' on Fedora Core 1:
[root@jmontleon-note root]# /sbin/parted /dev/hda print
Disk geometry for /dev/hda: 0.000-38154.375 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031  22266.562  primary   ntfs        boot
2      22266.562  29959.453  primary   ext3
3      29959.453  30461.484  primary   linux-swap
4      30461.484  38154.375  primary   ext3
Information: Don't forget to update /etc/fstab, if necessary.

'grub --no-floppy' on Fedora Core 
1:                                                                    
            
    GRUB  version 0.93  (640K lower / 3072K upper memory)
                                                                      
          
 [ Minimal BASH-like line editing is supported.  For the first word, 
TAB
   lists possible command completions.  Anywhere else TAB lists the 
possible
   completions of a device/filename.]
                                                                      
          
grub> geometry (hd0)

drive 0x80: C/H/S = 5168/240/63, The number of sectors = 
78140160, /dev/hda
   Partition num: 0,  Filesystem type unknown, partition type 0x7
   Partition num: 1,  Filesystem type is ext2fs, partition type 0x83
   Partition num: 2,  Filesystem type unknown, partition type 0x82
   Partition num: 3,  Filesystem type is ext2fs, partition type 0x83

geometry (hd0) from grub prompt at boot for FC2:

'modprobe edd' on FC1
I was able to do 'modprobe edd' on Fedora Core 1 but there is no /sys 
directory so I've no idea where to grab this information from, or if 
it is even available as you were asking for it; if it is somewhere 
and you need it I will grab it.

'/sbin/parted /dev/hda print' on Fedora Core 2:
[root@fc2 root]# /sbin/parted /dev/hda print
Disk geometry for /dev/hda: 0.000-38154.375 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031  22266.562  primary   ntfs        boot
2      22266.562  29959.453  primary   ext3
3      29959.453  30461.484  primary   linux-swap
4      30461.484  38154.375  primary   ext3
Information: Don't forget to update /etc/fstab, if necessary.
 
[root@fc2 root]#

'grub --no-floppy' on Fedora Core 2:
    GNU GRUB  version 0.94  (640K lower / 3072K upper memory)
                                                                      
          
 [ Minimal BASH-like line editing is supported.  For the first word, 
TAB
   lists possible command completions.  Anywhere else TAB lists the 
possible    completions of a device/filename.]
                                                                      
          
grub> geometry (hd0)
drive 0x80: C/H/S = 65535/16/63, The number of sectors = 
78140160, /dev/hda                    
   Partition num: 0,  Filesystem type unknown, partition type 0x7
   Partition num: 1,  Filesystem type is ext2fs, partition type 0x83
   Partition num: 2,  Filesystem type unknown, partition type 0x82
   Partition num: 3,  Filesystem type is ext2fs, partition type 0x83
                                                                      
          
grub>

The above C/H/S values differ...

'geometry (hd0)' from grub prompt at boot for FC2 (albeit chainloaded 
from XP bootloader):
Both FC1 and FC2 report 1023/240/63 when I run 'geometry (hd0)' from 
a grub prompt before booting; is 1023 due to the BIOS limitation, and 
FC2 differs from what FC1.  The only other differentiation is grub 
for FC1 reports version 0.93, and 0.94 for FC2.  All other numbers 
are identical to those above for FC1 and PM8 and bootpart:

http://www.montleon.com/pm8.png

'modprobe edd'  on FC2:
[root@fc2 int13_dev80]# ls
default_cylinders          extensions  interface         
legacy_sectors  sectors
default_heads              host_bus    legacy_cylinders  
mbr_signature   version
default_sectors_per_track  info_flags  legacy_heads      raw_data
[root@fc2 int13_dev80]# cat default_cylinders
0x3fff
[root@fc2 int13_dev80]# cat default_heads
0x10
[root@fc2 int13_dev80]# cat default_sectors_per_track
0x3f
[root@fc2 int13_dev80]# cat extensions
Fixed disk access
Enhanced Disk Drive support
[root@fc2 int13_dev80]# cat host_bus
PCI     00:1f.7  channel: 0
[root@fc2 int13_dev80]# cat info_flags
DMA boundary error transparent
[root@fc2 int13_dev80]# cat interface
ATA             device: 0
[root@fc2 int13_dev80]# cat legacy_cylinders
0x3fe
[root@fc2 int13_dev80]# cat legacy_heads
0xef
[root@fc2 int13_dev80]# cat legacy_sectors
0x3f
[root@fc2 int13_dev80]# cat mbr_signature
0x26402640
[root@fc2 int13_dev80]# cat raw_data
J�??S��@ݾ,PCI ATA     �[root@fc2 int13_dev80]#
[root@fc2 int13_dev80]# sectors
-bash: sectors: command not found
[root@fc2 int13_dev80]# cat sectors
0x4a85300
[root@fc2 int13_dev80]# cat version
0x30
[root@fc2 int13_dev80]#

'df -kh' on FC2 (just as a comparison to the 100% full PM8 says):
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda4             7.3G  3.5G  3.5G  51% /
none                  126M     0  126M   0% /dev/shm
[root@fc2 /]#
Comment 12 Jason Montleon 2004-04-28 21:59:32 EDT
This problem is still occuring in Test3.  I deleted, recreated, and
formatted the partition ext3.  The same problem is occuring, except
that now when viewing it through Partition Magic it shows the real
full/empty space rather than reporting it 100% full.  It is also
browseable using the Partition Browser tool that comes with PM8. 
Otherwise all the same errors occur, and grub still reports the
incorrect geometry:

                                                                     
          
    GNU GRUB  version 0.94  (640K lower / 3072K upper memory)
                                                                     
          
 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the
possible
   completions of a device/filename.]
                                                                     
          
grub> geometry (hd0)
drive 0x80: C/H/S = 65535/16/63, The number of sectors = 78140160,
/dev/hda
   Partition num: 0,  Filesystem type unknown, partition type 0x7
   Partition num: 1,  Filesystem type is ext2fs, partition type 0x83
   Partition num: 2,  Filesystem type unknown, partition type 0x82
   Partition num: 3,  Filesystem type is ext2fs, partition type 0x83
                                                                     
          
grub>
                                                                     
          
Comment 13 Jason Montleon 2004-04-28 22:01:32 EDT
I should add that PM8 maintained the ability to read the the partition
label for the FC2 partition after installing FC2T3 as well; this was
not the case with Test2.
Comment 14 Anthony DeStefano 2004-05-17 20:21:11 EDT
Created attachment 100285 [details]
Output from commands on FC2T3

I'll add a me too to the list.	My problem was after install FC2T3 onto
/dev/hdc with XP on /dev/hda.  My hardware is an Asus A7N8X using onboard
controller, /dev/hda is a 80GB WD, and /dev/hdc is a 17GB Maxtor.  I have also
attached the output from the above commands.
Comment 15 Anthony DeStefano 2004-05-17 20:22:17 EDT
I forgot to mention my work around was to change the BIOS from auto
detection mode and force LBA mode for all disks.
Comment 16 Didier 2004-05-18 03:35:05 EDT
Same experience with FC2t2, FC2t3 and FC2, with two different disk
geometries (Hitachi HTS726060M9AT00 60 GB and IBM Travelstar
IC25T060ATCS05-0 48 GB) : dual booting with a previously installed
Win2000 resulted in the dreaded "NTLDR is missing".


The only solution which worked for me (as I do not have an
LBA/Autodetect setting in my IBM ThinkPad A30p BIOS) :

1. get a MS WinME Emergency floppy ;
2. boot from floppy, copy A:\IO.SYS to
C:\WINDOWS\COMMAND\EBD\WINBOOT.SYS (mandatory for the SYS C: in step 3.) ;
3. SYS C: (this writes an updated disk geometry, which gets
interpreted by Win2000 in step 5.) ;
4. boot from Win2000 installation CD-ROM, go to Recovery Console ;
5. FIXMBR {xyz}  (with {xyz} the result of MAP) ;
6. FIXBOOT C:

This allows Win2K to boot again.

7. boot from FC2 installation CD-ROM, "linux rescue"
8. # chroot /mnt/sysimage
9. # grub-install /dev/hda  (or go to the grub console and 'install')


Definitely a regression of FC1.
Comment 17 Marcel Majoor 2004-07-24 12:07:44 EDT
Problem also occurs when during install additional partitions are
created. It typically happens when Windows did not boot from the first
partition. The partition identifier (number) which is used for the
Windows boot process is then no longer correct (because of the added
partitions). For instance in my situation the boot partition was
´partition(2)´ but had to be corrected to ´partition(4)´.

Fix: Start from bootable Windows CD. Use R(epair) option (Recovery
console). Select the number of one of the Windows installations shown.
Then use ´BOOTCFG /REBUILD´, and add all detected Windows
installations. The ´Load Identifier´ you need to enter is the name
shown to you during bootselection. When done, reboot. When booting,
select your new ´Load identifier´ name.
You typically want to correct the boot-list manually after that
because the originals (with incorrect partition references) are still
in the list. Do this through System - Advanced - Startup and recovery
-> edit the boot file.
Comment 18 Pádraig Brady 2004-10-06 10:45:22 EDT
Is this not a dupe of 115980
Anyway why is 115980 not closed yet?
Comment 19 davis liu 2004-12-06 22:06:18 EST
Hi, 
I installed FC3 to my compaq S8000 with XP and try to dual boot.

After reinstalling Fedora Core 3, I selected fedora, it worked fine. 
But when I rebooted and selected XP again, XP goes to recovery. After 
2 hours recovery, XP could come up and GRUB was gone. 

I wonder if this problem is fixed or not in FC3. 

The workarounds require FC1 and can any one tell me where to get it?

I try to use mkbootdisk from the rescue shell to make a floppy boot 
and it does not work.

Is there any better workaround?

Note You need to log in before you can comment on or make changes to this bug.