Bug 116674 - kernel breaks Dell Inspiron 8000's touchpad's tap-for-click until power cycle
kernel breaks Dell Inspiron 8000's touchpad's tap-for-click until power cycle
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 120267 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-24 05:37 EST by Alexandre Oliva
Modified: 2015-01-04 17:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:02:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
linux-tp.patch (305 bytes, patch)
2004-03-19 18:32 EST, Tim Waugh
no flags Details | Diff

  None (edit)
Description Alexandre Oliva 2004-02-24 05:37:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
Earlier FC2test1 kernels had the same problem.  Simply booting this
kernel is enough to disable the tap-for-click feature of the touchpad.
 Even after rebooting into FC1, it won't work.  I have to power-cycle
the laptop in order for it to work.

Ideally, tap-for-click should work out of the box, but I haven't
managed to get this to work at all (haven't tried the synaptics
driver, I'd rather not have to install non-FC software on the test
system).  I've tried both the default FC2test1 settings (that used to
work until some 2.6.2 or 2.6.3 update), then I changed /dev/psaux to
/dev/input/mice.  No tap-for-click.

I tried a single mouse entry in XF86Config, removing the DevInputMice
entry, to no avail.  I tried changing the protocol to ExplorerPS/2,
that AFAIK is the protocol used by the kernel for /dev/input/mice
nowadays, and booting with psmouse.proto=imps, and this completely
disabled the tracking stick (Dell DualPoint).

Suggestions?

Version-Release number of selected component (if applicable):
kernel-2.6.3-1.91

How reproducible:
Always

Steps to Reproduce:
1.Boot a Dell laptop with DualPoint into FC2test1+updates
2.Test tapping the touchpad
3.Reboot into FC1
4.Test again
5.Power cycle
6.Test again

Actual Results:  2. and 4. fail; 6 works.

Expected Results:  4 should have worked, but the kernel apparently
leaves some wrong setting behind.  Ideally, 2 should work out of the
box as well.

Additional info:

Messages I get on boot:

Synaptics Touchpad, model: 1
 Firmware: 5.6
 180 degree mounted touchpad
 Sensor: 1
 new absolute packet format
 Touchpad has extended capability bits
 -> multifinger detection
 -> palm detection
 -> pass-through port
input: SynPS/2 Synaptics TouchPad on isa0060/serio1
serio: Synaptics pass-through port at isa0060/serio1/input0
input: PS/2 Generic Mouse on synaptics-pt/serio0
serio: i8042 KBD port at 0x60,0x64 irq 1
Comment 1 Jim Cornette 2004-03-03 20:00:37 EST
I have a laptop with a synaptics touchpad that is an hp pavilion
4315us. I am holding back on trying the full beta (2.6 kernel) because
of the loss of the tap feature and the scroll capabilities of the device.

I have tried the 2.6 kernel before on this computer and went back to
the 2.4 kernel because of this.
Comment 2 Christopher Johnson 2004-03-12 08:11:43 EST
I have a Compaq Presario 2100 laptop which has a synaptics touchpad.
Click-on-tap and scroll do not work on any 2.6 kernel up through
2.6.3-2.1.240, and I haven't tested any newer ones.  Work fine on 2.4
kernels.
Comment 3 Tim Waugh 2004-03-18 17:15:50 EST
Any news on this?  Happens for Dell Inspiron 3500 too.
Comment 4 Tim Waugh 2004-03-19 18:32:52 EST
Created attachment 98699 [details]
linux-tp.patch

Here is the fix.
Comment 5 Tim Waugh 2004-03-20 05:32:17 EST
Hmm, actually perhaps it should be 'if (!value) break;'.  Testing that
now.
Comment 6 Tim Waugh 2004-03-21 07:41:18 EST
That wasn't it either.

However, Peter Osterlund suggested booting with:

  psmouse.proto=imps

on the kernel command line, and that works (after a power-cycle).

Additionally, 2.6.5-rc1 includes some changes that reset the protocol
state properly without needing a power-cycle.
Comment 7 Alexandre Oliva 2004-03-21 18:42:46 EST
I mentioned psmouse.proto=imps in the initial bug report.  It kills
the tracking stick, that works in synaptics pass-through mode.
Comment 8 Tim Waugh 2004-04-07 10:15:35 EDT
*** Bug 120267 has been marked as a duplicate of this bug. ***
Comment 9 Jim Cornette 2004-04-07 18:23:23 EDT
I still have a laptop with a synaptic mousepad that is awaiting a
resolution to this problem.

This is good news for the 2.4 kernel FC1 distro. It makes the demand
for the 2.4 kernel based distro with synaptic support to outweigh the
2.6 kernel version FC2 without synaptic support natively.
Typing on the FC1 restricted laptop now.
Comment 10 Paul Nasrat 2004-04-08 08:52:51 EDT
I don't think you can get pass-thru to work properly using
psmouse.proto for the tracking stick.  What does kudzu report if you do

python
>>> import kudzu
>>> kudzu.probe(kudzu.CLASS_MOUSE,kudzu.BUS_UNSPEC,kudzu.PROBE_ALL)

without psmouse.proto=imps

I'm pretty sure that where it limits stuff you won't end up picking up
the second pointer device.  My HP Omnibook is the same

Synaptics driver http://w1.894.telia.com/~u89404340/touchpad/

is available as src.rpm here building against xorg-x11-sdk:

http://pauln.truemesh.com/rpms/

I'd still like to get this into FC2...
Comment 11 Mike Becker 2004-04-08 10:03:32 EDT
FYI:
I just installed FC2-T2 on my Gateway M500 laptop and as it has been
the case with the 3 distros I have tried in which a 2.6 kernel used,
the double-tap function of the Synaptics Touchpad used on this system
failed to work.  As it has been reported, the system must be powered
off to 'correct' this.  Just doing a reboot will not clear this problem!

However, by adding to my GRUB's kernel command line
'psmouse.proto=imps' enables the double-tap function...
Comment 12 Dave Jones 2004-12-08 00:38:24 EST
fixed in the latest kernel update ?
Comment 13 Dave Jones 2005-04-16 00:02:07 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.