Bug 116675 - vim in gnome-terminal displays terminal control sequences
Summary: vim in gnome-terminal displays terminal control sequences
Status: CLOSED DUPLICATE of bug 115499
Alias: None
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-24 10:42 UTC by Alexandre Oliva
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2004-02-24 10:42:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
If you start vim within gnome-terminal, without arguments, the second
line will contain `^[34m' before the expected `~' character, as well
as in every `type :' line.  If you open a small file, the line below
the last line of the file will contain this same sequence.  If it's a
big file, the one-before-last line in the screen, will contain this
sequence as well.  I don't know whether this is a terminal emulation
bug in gnome-terminal/vte or an incorrect sequence issued by vim.

Version-Release number of selected component (if applicable):
vim-enhanced-6.2.253-2

How reproducible:
Always

Steps to Reproduce:
1.Start vim
2.Start vim small-file
3.Start vim big-file
    

Actual Results:  The `^[34m' sequence is displayed in all cases, as
described above.

Expected Results:  It shouldn't.

Additional info:

Comment 1 Karsten Hopp 2004-02-24 11:41:32 UTC

*** This bug has been marked as a duplicate of 115499 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:01:36 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.