Bug 115499 - 'xterm' terminal broken
'xterm' terminal broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ncurses (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
: 115902 116675 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-12 21:07 EST by Enrico Scholz
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version: 5.4-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-30 10:25:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2004-02-12 21:07:49 EST
Description of problem:

With 'TERM=xterm' and current ncurses I get some strange effects:

* 'mc' in xterm is monochrom only, but in gnome-terminal it has normal
colors. Setting 'TERM=xterm-color' makes it colorized in xterm again,
but some keys are broken there.

* 'vim' displays a '^[34m' string


When using the xterm terminfo-file from ncurses-5.3, things are fine
again.


Version-Release number of selected component (if applicable):

ncurses-5.4-1
Comment 1 Miloslav Trmac 2004-02-13 21:23:05 EST
Looks like a duplciate of bug 115448.
Comment 2 Bill Nottingham 2004-02-17 00:26:37 EST
*** Bug 115902 has been marked as a duplicate of this bug. ***
Comment 3 Karsten Hopp 2004-02-24 06:41:35 EST
*** Bug 116675 has been marked as a duplicate of this bug. ***
Comment 4 Eido Inoue 2004-02-25 15:49:49 EST

*** This bug has been marked as a duplicate of 115448 ***
Comment 5 Bastien Nocera 2004-02-26 07:16:37 EST
This bug can be worked around by using "export TERM=xterm-color"
Comment 6 Enrico Scholz 2004-02-26 07:36:02 EST
xterm-color has broken keys:

1. set 'XTerm*termName: xterm-color' resource in ~/.Xresources
2. xrdb ~/.Xresources
3. xterm
4. vim
--> press i + Backspace  --> literal '^?' appears (or a beep)
Comment 7 Eido Inoue 2004-02-26 14:21:03 EST
comment 6: doh! you're right. remapping. will be fixed in 5.4-4
Comment 8 Alexandre Oliva 2004-07-17 16:14:34 EDT
The `* 'vim' displays a '^[34m' string' bug is back in gnome-terminal
on today's rawhide (FC3test1+updates).  The following packages are
running:
gnome-terminal-2.6.0-4
vim-enhanced-6.3.013-1
ncurses-5.4-10.fc3

I haven't noticed the problem before installing updates, but since I
don't use vi much, it may well have gone unnoticed.
Comment 9 Karsten Hopp 2004-07-22 05:10:24 EDT
The vi '^[34m' string was a different bug 128344. 
A lengthy discussion about all the ncurses applications being 
monochrome only (again) is going on in bug 122815, so this one might 
be a candidate for 'duplicate' 
Comment 10 Alexandre Oliva 2004-07-30 03:04:41 EDT
Closing again, the problem seems to be fixed.
Comment 11 Leonard den Ottolander 2004-07-30 09:57:52 EDT
What kind of status is ON_DEV? It's not described in
https://bugzilla.redhat.com/bugzilla/bug_status.cgi. Also if the bug
is fixed shouldn't the bug be closed with a proper resolution?
Comment 12 Leonard den Ottolander 2004-07-30 10:02:42 EDT
Sorry, slip of the mouse that "NOTABUG".
Comment 13 Alexandre Oliva 2004-07-30 10:25:08 EDT
Must have been a slip of the mouse on my end as well.  I meant to
choose resolved/rawhide.

Note You need to log in before you can comment on or make changes to this bug.