Bug 116687 - tcl.h and tk.h not found
tcl.h and tk.h not found
Status: CLOSED DUPLICATE of bug 108621
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distribution (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jens Petersen
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-24 07:22 EST by Thomas Baumann
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Baumann 2004-02-24 07:22:08 EST
Description of problem:

tcl-devel and tk-devel binary rpms are not available from
redhat network, but tcl.h and tk.h are needed for compiling
some applications.

Version-Release number of selected component (if applicable):

8.3.5-92

How reproducible:

look at the spec file tcltk.spec
you find several sections for building the *-devel packages
  
Where can these found for rhel 3as ?

Additional info:

// Thomas Baumann // tirili
Comment 1 Jens Petersen 2004-02-24 21:11:43 EST
Unfortunately the -devel packages were not included with the initial
RHEL 3 release, however I believe they are going to be made available
before too long.  In the meantime the easiest way for you to get them
is probably just to rebuild the tcltk package from the srpm.

*** This bug has been marked as a duplicate of 108621 ***
Comment 2 Thomas Baumann 2004-02-25 03:03:52 EST
How can I get the rebuild packages tcl-devel and tk-devel with a
gpg-signature of redhat (RPM-GPG-KEY) ? I know how to rebuild, but
when perfoming a rpm -K the singature fails.

Thanks for your help in advance.

Thomas.
Comment 3 Jens Petersen 2004-02-25 05:51:58 EST
You can't is the simple answer: otherwise there would little
point in having packages signed. ;)

Of course you can still install the unsigned packages and use
them without any problem.
Comment 4 Red Hat Bugzilla 2006-02-21 14:01:36 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.