Bug 1167250 - [abrt] libreoffice-core: set(): soffice.bin killed by SIGABRT
Summary: [abrt] libreoffice-core: set(): soffice.bin killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephan Bergmann
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:d5729802fa0983b322ba76147a2...
: 888782 920838 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-24 10:05 UTC by Viktor Matveenko
Modified: 2014-12-04 06:24 UTC (History)
7 users (show)

Fixed In Version: libreoffice-4.2.7.2-11.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-04 06:24:00 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (99.06 KB, text/plain)
2014-11-24 10:05 UTC, Viktor Matveenko
no flags Details
File: cgroup (180 bytes, text/plain)
2014-11-24 10:05 UTC, Viktor Matveenko
no flags Details
File: core_backtrace (56.04 KB, text/plain)
2014-11-24 10:05 UTC, Viktor Matveenko
no flags Details
File: dso_list (31.03 KB, text/plain)
2014-11-24 10:05 UTC, Viktor Matveenko
no flags Details
File: environ (2.19 KB, text/plain)
2014-11-24 10:05 UTC, Viktor Matveenko
no flags Details
File: limits (1.29 KB, text/plain)
2014-11-24 10:05 UTC, Viktor Matveenko
no flags Details
File: maps (149.66 KB, text/plain)
2014-11-24 10:05 UTC, Viktor Matveenko
no flags Details
File: open_fds (1.24 KB, text/plain)
2014-11-24 10:05 UTC, Viktor Matveenko
no flags Details
File: proc_pid_status (951 bytes, text/plain)
2014-11-24 10:05 UTC, Viktor Matveenko
no flags Details
File: var_log_messages (229 bytes, text/plain)
2014-11-24 10:05 UTC, Viktor Matveenko
no flags Details

Description Viktor Matveenko 2014-11-24 10:05:22 UTC
Version-Release number of selected component:
libreoffice-core-4.2.7.2-7.fc20

Additional info:
reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer '/home/HetmanNet/\xd0\x9a\xd0\xbd\xd0\xb8\xd0\xb6\xd0\xba\xd0\xb8/\xd0\xa8\xd0\xb5\xd0\xbd\xd1\x8c \xd0\x9f\xd1\x80\xd0\xbe\xd0\xb3\xd1\x80\xd0\xb0\xd0\xbc\xd0\xbc\xd0\xb8\xd1\x80\xd0\xbe\xd0\xb2\xd0\xb0\xd0\xbd\xd0\xb8\xd0\xb5 \xd0\xa2\xd0\xb5\xd0\xbe\xd1\x80\xd0\xb5\xd0\xbc\xd1\x8b \xd0\xb8 \xd0\xb7\xd0\xb0\xd0\xb4\xd0\xb0\xd1\x87\xd0\xb8.doc' --splash-pipe=5
crash_function: set
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.17.2-200.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 set at /usr/src/debug/libreoffice-4.2.7.2/include/com/sun/star/uno/Reference.hxx:222
 #7 operator= at /usr/src/debug/libreoffice-4.2.7.2/include/com/sun/star/uno/Reference.hxx:329
 #8 X11SalInstance::CreateClipboard at /usr/src/debug/libreoffice-4.2.7.2/vcl/unx/generic/dtrans/X11_service.cxx:84
 #9 vcl::ClipboardFactory::createInstanceWithArguments at /usr/src/debug/libreoffice-4.2.7.2/vcl/source/components/dtranscomp.cxx:255
 #10 cppuhelper::ServiceManager::createInstanceWithArgumentsAndContext at /usr/src/debug/libreoffice-4.2.7.2/cppuhelper/source/servicemanager.cxx:823
 #11 Window::GetPrimarySelection at /usr/src/debug/libreoffice-4.2.7.2/vcl/source/window/window.cxx:8553
 #12 TransferableHelper::CopyToSelection at /usr/src/debug/libreoffice-4.2.7.2/svtools/source/misc/transfer.cxx:1085
 #13 SwTransferable::CreateSelection at /usr/src/debug/libreoffice-4.2.7.2/sw/source/ui/dochdl/swdtflvr.cxx:3492
 #14 SwWrtShell::SelAll at /usr/src/debug/libreoffice-4.2.7.2/sw/source/ui/wrtsh/select.cxx:160
 #15 SwTextShell::ExecMove at /usr/src/debug/libreoffice-4.2.7.2/sw/source/ui/shells/txtcrsr.cxx:123

Comment 1 Viktor Matveenko 2014-11-24 10:05:25 UTC
Created attachment 960637 [details]
File: backtrace

Comment 2 Viktor Matveenko 2014-11-24 10:05:27 UTC
Created attachment 960638 [details]
File: cgroup

Comment 3 Viktor Matveenko 2014-11-24 10:05:28 UTC
Created attachment 960639 [details]
File: core_backtrace

Comment 4 Viktor Matveenko 2014-11-24 10:05:30 UTC
Created attachment 960640 [details]
File: dso_list

Comment 5 Viktor Matveenko 2014-11-24 10:05:31 UTC
Created attachment 960641 [details]
File: environ

Comment 6 Viktor Matveenko 2014-11-24 10:05:32 UTC
Created attachment 960642 [details]
File: limits

Comment 7 Viktor Matveenko 2014-11-24 10:05:35 UTC
Created attachment 960643 [details]
File: maps

Comment 8 Viktor Matveenko 2014-11-24 10:05:36 UTC
Created attachment 960644 [details]
File: open_fds

Comment 9 Viktor Matveenko 2014-11-24 10:05:37 UTC
Created attachment 960645 [details]
File: proc_pid_status

Comment 10 Viktor Matveenko 2014-11-24 10:05:38 UTC
Created attachment 960646 [details]
File: var_log_messages

Comment 11 Stephan Bergmann 2014-11-24 10:56:25 UTC
*** Bug 888782 has been marked as a duplicate of this bug. ***

Comment 12 Stephan Bergmann 2014-11-24 10:56:34 UTC
*** Bug 920838 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2014-11-27 10:28:24 UTC
libreoffice-4.2.7.2-10.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreoffice-4.2.7.2-10.fc20

Comment 14 Fedora Update System 2014-11-28 09:50:53 UTC
libreoffice-4.2.7.2-11.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreoffice-4.2.7.2-11.fc20

Comment 15 Fedora Update System 2014-12-01 18:59:24 UTC
Package libreoffice-4.2.7.2-11.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-4.2.7.2-11.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16000/libreoffice-4.2.7.2-11.fc20
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2014-12-04 06:24:00 UTC
libreoffice-4.2.7.2-11.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.