Bug 888782 - [abrt] libreoffice-core-3.5.7.2-7.fc17: SEGV in X11SalInstance::CreateClipboard
[abrt] libreoffice-core-3.5.7.2-7.fc17: SEGV in X11SalInstance::CreateClipboard
Status: CLOSED DUPLICATE of bug 1167250
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:737907402d23638e39d3f480a64...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-19 08:28 EST by adressespecialepub
Modified: 2014-11-24 05:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 07:26:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (5.62 KB, text/plain)
2012-12-19 08:28 EST, adressespecialepub
no flags Details
File: environ (2.82 KB, text/plain)
2012-12-19 08:28 EST, adressespecialepub
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-19 08:28 EST, adressespecialepub
no flags Details
File: backtrace (92.86 KB, text/plain)
2012-12-19 08:28 EST, adressespecialepub
no flags Details
File: cgroup (126 bytes, text/plain)
2012-12-19 08:28 EST, adressespecialepub
no flags Details
File: smolt_data (2.77 KB, text/plain)
2012-12-19 08:28 EST, adressespecialepub
no flags Details
File: executable (42 bytes, text/plain)
2012-12-19 08:28 EST, adressespecialepub
no flags Details
File: maps (111.60 KB, text/plain)
2012-12-19 08:28 EST, adressespecialepub
no flags Details
File: dso_list (25.62 KB, text/plain)
2012-12-19 08:28 EST, adressespecialepub
no flags Details
File: proc_pid_status (927 bytes, text/plain)
2012-12-19 08:29 EST, adressespecialepub
no flags Details
File: open_fds (2.43 KB, text/plain)
2012-12-19 08:29 EST, adressespecialepub
no flags Details
File: var_log_messages (354 bytes, text/plain)
2012-12-19 08:29 EST, adressespecialepub
no flags Details

  None (edit)
Description adressespecialepub 2012-12-19 08:28:29 EST
Version-Release number of selected component:
libreoffice-core-3.5.7.2-7.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --calc file:///tmp/S6%20TEO%202012-2013.xls --splash-pipe=6
crash_function: Reference
kernel:         3.6.10-2.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 Reference at /usr/src/debug/libreoffice-3.5.7.2/solver/unxlngx6.pro/inc/com/sun/star/uno/Reference.hxx:131
: #1 X11SalInstance::CreateClipboard at /usr/src/debug/libreoffice-3.5.7.2/vcl/unx/generic/dtrans/X11_service.cxx:119
: #2 vcl::ClipboardFactory::createInstanceWithArguments at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/components/dtranscomp.cxx:275
: #3 cppu::ORegistryFactoryHelper::createInstanceWithArgumentsAndContext at /usr/src/debug/libreoffice-3.5.7.2/cppuhelper/source/factory.cxx:821
: #4 stoc_smgr::OServiceManager::createInstanceWithArgumentsAndContext at /usr/src/debug/libreoffice-3.5.7.2/stoc/source/servicemanager/servicemanager.cxx:1255
: #5 stoc_smgr::OServiceManager::createInstanceWithArguments at /usr/src/debug/libreoffice-3.5.7.2/stoc/source/servicemanager/servicemanager.cxx:1311
: #6 Window::GetPrimarySelection at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/window/window.cxx:8434
: #7 TransferableHelper::CopyToSelection at /usr/src/debug/libreoffice-3.5.7.2/svtools/source/misc/transfer.cxx:1084
: #8 ScTabView::CheckSelectionTransfer at /usr/src/debug/libreoffice-3.5.7.2/sc/source/ui/view/tabview3.cxx:334
: #9 ScTabView::UpdateAutoFillMark at /usr/src/debug/libreoffice-3.5.7.2/sc/source/ui/view/tabview3.cxx:164
Comment 1 adressespecialepub 2012-12-19 08:28:32 EST
Created attachment 666060 [details]
File: core_backtrace
Comment 2 adressespecialepub 2012-12-19 08:28:36 EST
Created attachment 666061 [details]
File: environ
Comment 3 adressespecialepub 2012-12-19 08:28:39 EST
Created attachment 666062 [details]
File: limits
Comment 4 adressespecialepub 2012-12-19 08:28:41 EST
Created attachment 666063 [details]
File: backtrace
Comment 5 adressespecialepub 2012-12-19 08:28:44 EST
Created attachment 666064 [details]
File: cgroup
Comment 6 adressespecialepub 2012-12-19 08:28:46 EST
Created attachment 666066 [details]
File: smolt_data
Comment 7 adressespecialepub 2012-12-19 08:28:50 EST
Created attachment 666068 [details]
File: executable
Comment 8 adressespecialepub 2012-12-19 08:28:55 EST
Created attachment 666071 [details]
File: maps
Comment 9 adressespecialepub 2012-12-19 08:28:58 EST
Created attachment 666073 [details]
File: dso_list
Comment 10 adressespecialepub 2012-12-19 08:29:00 EST
Created attachment 666074 [details]
File: proc_pid_status
Comment 11 adressespecialepub 2012-12-19 08:29:06 EST
Created attachment 666078 [details]
File: open_fds
Comment 12 adressespecialepub 2012-12-19 08:29:09 EST
Created attachment 666079 [details]
File: var_log_messages
Comment 13 Michael Stahl 2013-01-04 14:39:44 EST
hmm... crash on the return statement, copying the Reference in the map:

    static boost::unordered_map< OUString, ::boost::unordered_map< Atom, Reference< XClipboard > >, ::rtl::OUStringHash > m_aInstances;

[...]

    ::boost::unordered_map< Atom, css::uno::Reference< XClipboard > >& rMap( m_aInstances[ aDisplayName ] );
    ::boost::unordered_map< Atom, css::uno::Reference< XClipboard > >::iterator it = rMap.find( nSelection );
    if( it != rMap.end() )
        return it->second;


odd thing to crash in this way, no idea how it could happen...

can you reproduce this somehow?
Comment 14 Stephan Bergmann 2014-11-24 05:56:25 EST

*** This bug has been marked as a duplicate of bug 1167250 ***

Note You need to log in before you can comment on or make changes to this bug.