Bug 1167623 - Remove "If reporting bugs, run virt-v2v with debugging enabled .." message when running virt-p2v
Summary: Remove "If reporting bugs, run virt-v2v with debugging enabled .." message wh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pino Toscano
QA Contact: Virtualization Bugs
URL:
Whiteboard: P2V
Depends On: 1218766 1359086
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-11-25 07:59 UTC by tingting zheng
Modified: 2017-08-01 22:08 UTC (History)
10 users (show)

Fixed In Version: libguestfs-1.36.2-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 22:08:55 UTC


Attachments (Terms of Use)
Log file of virt-p2v (54.19 KB, text/plain)
2014-11-25 07:59 UTC, tingting zheng
no flags Details
log (70.78 KB, text/plain)
2017-03-20 09:27 UTC, kuwei@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2023 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2017-08-01 19:32:01 UTC

Description tingting zheng 2014-11-25 07:59:01 UTC
Created attachment 961060 [details]
Log file of virt-p2v

Description
Improve the log info in virt-p2v log file

Version:
virt-v2v-1.28.1-1.13.el7.x86_64
livecd-p2v-201411201732.iso

How reproducible:
100%

Steps to Reproduce:
1.Launch virt-p2v boot GUI via iso or virt-p2v image.

2.Use virt-p2v to convert a host without operating system installed.

3.The conversion fails and connection closed

4.Check virt-p2v log file,error info shows as below:
virt-v2v: error: no root device found in this operating system image.

If reporting bugs, run virt-v2v with debugging enabled and include the
complete output:

  virt-v2v -v -x [...]


Actual results:
In step 4,error info like "If reporting bugs, run virt-v2v with debugging enabled and include the complete output:virt-v2v -v -x [...]" shows.

Expected results:
In step 4,error info like "If reporting bugs, run virt-v2v with debugging enabled and include the complete output:virt-v2v -v -x [...]" should be removed.

Additional info:
Attach the log file.

Comment 2 Pino Toscano 2014-11-25 08:52:16 UTC
(In reply to tingting zheng from comment #0)
> Expected results:
> In step 4,error info like "If reporting bugs, run virt-v2v with debugging
> enabled and include the complete output:virt-v2v -v -x [...]" should be
> removed.

Can you please explain why?

Comment 3 tingting zheng 2014-11-25 10:03:10 UTC
(In reply to Pino Toscano from comment #2)
> (In reply to tingting zheng from comment #0)
> > Expected results:
> > In step 4,error info like "If reporting bugs, run virt-v2v with debugging
> > enabled and include the complete output:virt-v2v -v -x [...]" should be
> > removed.
> 
> Can you please explain why?

This log info comes from virt-p2v,I think you can not use virt-v2v -v -x to get virt-p2v debug info.

Comment 4 Richard W.M. Jones 2014-11-25 10:11:52 UTC
Tricky to implement since as far as virt-v2v is concerned
we're just running virt-v2v.  In any case this is cosmetic so
I'm moving it to RHEL 7.2.

Comment 6 Richard W.M. Jones 2015-05-15 10:19:10 UTC
I have a patch series which fixes this, but it's very invasive
so it's not RHEL 7.2 material.  However we are rebasing in RHEL 7.3
so we should be able to pick up the fix there.

The patches have been posted upstream:

https://www.redhat.com/archives/libguestfs/2015-May/msg00056.html

Comment 10 keanli 2016-05-30 02:58:34 UTC
Testing it with build:
libguestfs-1.32.4-2.el7.x86_64
virt-v2v-1.32.4-2.el7.x86_64
virt-p2v-1.32.4-1.el7.iso

Scenarios 1:Selected the "Enable server-side debugging" on the virt-p2v client
1.Launch virt-p2v boot GUI via iso or virt-p2v image.
2.Use virt-p2v to convert a host without operating system installed.
3.The conversion fails and connection closed
4.Check virt-p2v log file on the conversion server :
#cat virt-v2v-conversion-log.txt | grep virt-v2v
virt-v2v: libguestfs 1.32.4 (x86_64)
virt-v2v: warning: <target dev='sr0'> was ignored because the device name 
order to communicate with the backend virt-v2v process running
then virt-v2v will generate the real target libvirt XML, which
<name>virt-v2v_latestlog</name>
source name: virt-v2v_latestlog
libguestfs: launch: program=virt-v2v
virt-v2v: error: inspection could not detect the source guest (or physical 
Assuming that you are running virt-v2v/virt-p2v on a source which is 
happen. You should run 'virt-v2v -v -x ... >& log' and attach the complete 
log to a new bug report (see http://libguestfs.org).

Scenarios 2: Unselected the "Enable server-side debugging" on the virt-p2v client
1.Launch virt-p2v boot GUI via iso or virt-p2v image.
2.Use virt-p2v to convert a host without operating system installed.
3.The conversion fails and connection closed
4.Check virt-p2v log file on the conversion server :
#cat virt-v2v-conversion-log.txt | grep virt-v2v
virt-v2v: warning: <target dev='sr0'> was ignored because the device name 
virt-v2v: error: inspection could not detect the source guest (or physical 
Assuming that you are running virt-v2v/virt-p2v on a source which is 
happen. You should run 'virt-v2v -v -x ... >& log' and attach the complete 
If reporting bugs, run virt-v2v with debugging enabled and include the 
virt-v2v -v -x [...]

Test Result:
According the above test result, the bug is not fix

Comment 11 Richard W.M. Jones 2016-06-27 17:42:07 UTC
I feel we should remove the "Enable server-side debugging"
button as well.

Comment 12 Richard W.M. Jones 2016-07-02 09:12:17 UTC
(In reply to Richard W.M. Jones from comment #11)
> I feel we should remove the "Enable server-side debugging"
> button as well.

https://github.com/libguestfs/libguestfs/commit/0c04919f50685c583842b48ca035626753e959e5

Comment 15 kuwei@redhat.com 2017-03-20 01:48:57 UTC
Verify the bug with below builds:
virt-v2v-1.36.2-2.el7.x86_64
virt-p2v-maker-1.36.2-2.el7.x86_64
libguestfs-1.36.2-2.el7.x86_64

Steps:
1:Prepare a USB flash drives ,then using below command to make p2v boot usb disk 
# virt-p2v-make-disk -o /dev/sdb
[   2.9] Downloading: http://libguestfs.org/download/builder/fedora-25.xz
######################################################################## 100.0%
***********
[6814.6] Finishing off
                   Output file: /dev/sdb
                   Output size: 14.9G
                 Output format: raw
            Total usable space: 14.3G
                    Free space: 12.7G (89%)
*************
2:Launch virt-v2v boot usb to convert a host without operating system installed.
3.The conversion fails and connection closed.
4.Check virt-p2v log file on the conversion server :
#cat virt-v2v-conversion-log.txt | grep virt-v2v
virt-v2v: libguestfs 1.36.2 (x86_64)
  order to communicate with the backend virt-v2v process running
  then virt-v2v will generate the real target libvirt XML, which
libguestfs: launch: program=virt-v2v
virt-v2v: error: inspection could not detect the source guest (or physical 
Assuming that you are running virt-v2v/virt-p2v on a source which is 
happen.  You should run 'virt-v2v -v -x ... >& log' and attach the complete 

Result:The log also contain "You should run 'virt-v2v -v -x ... >& log'" 
so according the above test result, the bug is not fix.

Comment 16 kuwei@redhat.com 2017-03-20 07:04:36 UTC
Hi, rjones
 
Could we make a p2v(1.36.2-2) bootable usb key by virt-p2v-maker to test the bug or waiting you to build a  virt-p2v ISO ?

According to comment 15, We also could see  the info "virt-v2v -v -x ... >& log" in virt-v2v log file on the virt-v2v conversion server. I think the bug has not been fixed. Could you help to check this ?

Comment 17 Richard W.M. Jones 2017-03-20 08:39:08 UTC
(In reply to kuwei@redhat.com from comment #16)
> Hi, rjones
>  
> Could we make a p2v(1.36.2-2) bootable usb key by virt-p2v-maker to test the
> bug or waiting you to build a  virt-p2v ISO ?

Pino is waiting to build virt-p2v ISO.  There is some problem with
brew that stops it from being built at the moment.

However testing this using virt-p2v-maker should give the same results.

> According to comment 15, We also could see  the info "virt-v2v -v -x ... >&
> log" in virt-v2v log file on the virt-v2v conversion server. I think the bug
> has not been fixed. Could you help to check this ?

Can you attach the full virt-p2v-conversion-log file from
this run please.

Comment 18 kuwei@redhat.com 2017-03-20 09:27:48 UTC
Created attachment 1264724 [details]
log

Comment 19 Richard W.M. Jones 2017-03-20 15:17:34 UTC
Patch posted upstream:
https://www.redhat.com/archives/libguestfs/2017-March/msg00224.html

Comment 21 kuwei@redhat.com 2017-03-24 07:54:45 UTC
Verify the bug with below builds:
virt-v2v-1.36.2-3.el7.x86_64
virt-p2v-1.36.2-3
libguestfs-1.36.2-3.el7.x86_64

Steps:
1: Make a p2v(1.36.2-3) bootable usb key by virt-p2v-maker.
# virt-p2v-make-disk -o /dev/sdb rhel-7.3
[   4.4] Downloading: http://file.rdu.redhat.com/~rjones/builder/rhel-7.3.xz
***********
[1184.9] Finishing off
                   Output file: /dev/sdb
                   Output size: 14.9G
                 Output format: raw
            Total usable space: 13.9G
                    Free space: 12.6G (90%)
*************
2:Launch virt-p2v usb key to convert the host without operating system installed.
3.The conversion fails and connection closed.
4.Check virt-p2v log file on the conversion server :
#cat virt-v2v-conversion-log.txt | grep virt-v2v
virt-v2v: libguestfs 1.36.2 (x86_64)
  order to communicate with the backend virt-v2v process running
  then virt-v2v will generate the real target libvirt XML, which
libguestfs: launch: program=virt-v2v
virt-v2v: error: inspection could not detect the source guest (or physical 
Assuming that you are running virt-v2v/virt-p2v on a source which is 

Result:Would not report such info about "You should run "virt-v2v -v -x ... >& log"
So, move the bug to VERIFIED

Comment 22 errata-xmlrpc 2017-08-01 22:08:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2023


Note You need to log in before you can comment on or make changes to this bug.