Bug 116803 - Latest kernel build prevents X11 from starting under VMware
Latest kernel build prevents X11 from starting under VMware
Status: CLOSED DUPLICATE of bug 116118
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
other Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-25 08:29 EST by Alan G Dunkley
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full dmesg output (8.95 KB, text/plain)
2004-02-25 08:32 EST, Alan G Dunkley
no flags Details
Full XFree86 log (23.89 KB, text/plain)
2004-02-25 08:33 EST, Alan G Dunkley
no flags Details
New XFree86 config file from the system-config-display command (3.00 KB, text/plain)
2004-02-25 11:44 EST, Alan G Dunkley
no flags Details

  None (edit)
Description Alan G Dunkley 2004-02-25 08:29:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1)

Description of problem:
Since applying the latest development updates, X11 does not start.  It works when booting with kernel-2.6.1-1.65 but fails with kernel-2.6.3-1.[91,97,100]

It happens during the boot to runlevel 5 or by using the "startx" command, running as root has no effect on the problem so it not permissions.

As it works with a earlier kernel, its not the latest XFree builds. Has the major/minor numbers changed between the 2.6.1 & 2.6.3 trees?

Version-Release number of selected component (if applicable):
kernel-2.6.3-1.100

How reproducible:
Always

Steps to Reproduce:
1.Install FC2 into a VMware session
2.Update to the latest development set
3.reboot
4.Start X11
    

Actual Results:  Output from a "startx" command:

XFree86 Version 4.3.0 (Red Hat Rawhide develomental build: 4.3.0-59)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.21-4.ELsmp i686 [ELF]
Build Date: 20 February 2004
Build Host: tweety.devel.redhat.com

        Before reporting any problems, please make sure you are using the most
        recent XFree86 packages available from Red Hat by checking for updates
        at http://rhn.redhat.com/errata or by using the Red Hat Network up2date
        tool.  If you still encounter problems, please file bug reports in the
        XFree86.org bugzilla at http://bugs.xfree86.org and/or Red Hat
        bugzilla at http://bugzilla.redhat.com

Module Loader present
OS Kernel: Linux version 2.6.3-1.100 (bhcompile@porky.devel.redhat.com) (gcc version 3.3.3 20040216 (Red Hat Linux 3.3.3-2)) #1 Mon Feb 23 19:10:59 EST 2004
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Wed Feb 25 08:13:33 2004
(==) Using config file: "/etc/X11/XF86Config-4"
(WW) VMWARE(0): Failed to set up write-combining range (0xfd000000,0x1000000)
(EE) xf86OpenSerial: Cannot open device /dev/mouse
        No such device.
(EE) Mouse1: cannot open input device
(EE) PreInit failed for input device "Mouse1"
No core pointer

Fatal server error:
failed to initialize core devices

If you encounter a server crash, please report the problem by filing a bug
report in the XFree86.org bugzilla at http://bugs.xfree86.org and/or Red Hat
bugzilla at http://bugzilla.redhat.com/bugzilla.  When filing your report, it
is very important that you explain your problem in as much detail as possible,
and include a complete description on how to reproduce the problem.  After
submitting the bug report, attach the following files as uncompressed
individual file attachments using the bugzilla file attachment feature:
        - X server log file: /var/log/XFree86.0.log
        - X server config file: /etc/X11/XF86Config-4
        - Kernel log file: /var/log/messages

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.


Expected Results:  Should see KDE starting

Additional info:

Inspection of /dev shows:

[root@fc2 dev]# pwd
/dev
[root@fc2 dev]# ls -l mouse
lrwxrwxrwx  1 root root 5 Feb 19 15:08 mouse -> psaux
[root@fc2 dev]# ls -l psaux
crw-------  1 root root 10, 1 Feb 23 21:02 psaux
[root@fc2 dev]#

Some lines from dmesg:

atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0).
atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly.
atkbd.c: Unknown key released (translated set 2, code 0x7a on isa0060/serio0).
atkbd.c: This is an XFree86 bug. It shouldn't access hardware directly.
Comment 1 Alan G Dunkley 2004-02-25 08:32:03 EST
Created attachment 98034 [details]
Full dmesg output
Comment 2 Alan G Dunkley 2004-02-25 08:33:02 EST
Created attachment 98035 [details]
Full XFree86 log
Comment 3 Dave Jones 2004-02-25 09:49:48 EST
should be fixed in rawhide
Comment 4 Alan G Dunkley 2004-02-25 10:30:25 EST
Just updated my test system to all the latest development updates, 
including kernel-2.6.3-1.106 and the problem still persists. 
Comment 5 Arjan van de Ven 2004-02-25 10:35:30 EST
you need to create a new x config with the updated config tools
Comment 6 Alan G Dunkley 2004-02-25 11:44:45 EST
Created attachment 98046 [details]
New XFree86 config file from the system-config-display command
Comment 7 Alan G Dunkley 2004-02-25 11:48:37 EST
As suggested I create a new XF86Config file using the tool 
system-config-display but when I tried to start X11 with it using 
kernel 2.6.3-1.106 it failed as before.  I created it under 
2.6.1-1.65 as the command failed under the latest kernel.  I have 
attached the new configuration file to this ticket for reference. 
Comment 8 Alan G Dunkley 2004-02-25 12:07:32 EST
I dont believe its a XFree86 problem because with kernel 2.6.3-1.106 
an "od /dev/mouse" gives a such "no such device" error message, 
whereas I would expect it to return data, as soon as the mouse is 
moved, regardless of whether X11 is running or not. 
 
This too me suggests it is a kernel issue.  
Comment 9 Dave Jones 2004-02-25 12:21:18 EST
/dev/psaux is obsolete.
its been intentionally removed because of this.


*** This bug has been marked as a duplicate of 116118 ***
Comment 10 Red Hat Bugzilla 2006-02-21 14:01:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.