Bug 1168327 - Live Merge: optimize internal volume size
Summary: Live Merge: optimize internal volume size
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm
Classification: oVirt
Component: General
Version: ---
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ovirt-4.2.0
: 4.20.9
Assignee: Ala Hino
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
: 1420407 (view as bug list)
Depends On: 1041569
Blocks: 1497424
TreeView+ depends on / blocked
 
Reported: 2014-11-26 16:39 UTC by Adam Litke
Modified: 2019-04-28 09:39 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
After live merge, the base volume is reduced to its optimal size.
Clone Of:
Environment:
Last Closed: 2017-12-20 11:08:56 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
ratamir: testing_plan_complete-
ylavi: planning_ack+
rule-engine: devel_ack+
ratamir: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1170712 0 high CLOSED Live Merge: Failed to remove snapshot on block storage due to -ENOSPC 2021-02-22 00:41:40 UTC
oVirt gerrit 36924 0 'None' ABANDONED Live Merge: Restore watermark tracking 2021-02-19 14:30:11 UTC
oVirt gerrit 60889 0 'None' ABANDONED Live Merge: Restore watermark tracking 2021-02-19 14:30:11 UTC
oVirt gerrit 79866 0 'None' MERGED api: Introduce reduceVolume verb 2021-02-19 14:30:11 UTC
oVirt gerrit 79867 0 'None' MERGED lvm: Add support to force reduce LV 2021-02-19 14:30:11 UTC
oVirt gerrit 79868 0 'None' MERGED api: Implement reduceVolume verb 2021-02-19 14:30:11 UTC
oVirt gerrit 79870 0 'None' MERGED core: Reduce base volume after live merge 2021-02-19 14:30:12 UTC
oVirt gerrit 83218 0 'None' MERGED core: Update ReduceVolumeSupported to false up to version 4.2 2021-02-19 14:30:12 UTC

Internal Links: 1170712

Description Adam Litke 2014-11-26 16:39:53 UTC
Description of problem:

In order to efficiently resize internal block volumes during a live merge operation we need to query libvirt for the highest_wr_offset/allocation statistic for all volumes in a vmdrive's volume chain.  Currently libvirt is not providing such an API so we need to preemptively extend volumes.  Fix this once the API is available and enable on-demand extensions for live merge targets.

Comment 1 Allon Mureinik 2014-12-01 21:43:35 UTC
I don't see how libvirt will make it in time for oVirt 3.5.1 - moving out to 3.5.2.

Comment 2 Sandro Bonazzola 2015-03-03 12:56:44 UTC
Re-targeting to 3.5.3 since this bug has not been marked as blocker for 3.5.2 and we have already released 3.5.2 Release Candidate.

Comment 3 Yaniv Lavi 2015-08-19 15:45:20 UTC
Moving to 3.6 after consulting devel since it's risky and should be tested well.
Please consider giving private build to test prior to commit.

Comment 4 Red Hat Bugzilla Rules Engine 2015-10-19 10:55:10 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 5 Yaniv Lavi 2015-10-29 12:10:38 UTC
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.

Comment 6 Adam Litke 2015-11-23 16:55:59 UTC
Moving back to assigned as the posted patches are stale and not candidates for merging anymore.

Comment 7 Red Hat Bugzilla Rules Engine 2015-12-09 11:20:42 UTC
This bug is marked for z-stream, yet the milestone is for a major version, therefore the milestone has been reset.
Please set the correct milestone or drop the z stream flag.

Comment 8 Allon Mureinik 2016-02-15 12:00:11 UTC
*** Bug 1308375 has been marked as a duplicate of this bug. ***

Comment 11 Yaniv Kaul 2017-06-06 18:07:01 UTC
Duplicate of bug 1181665 ?

Comment 12 Allon Mureinik 2017-06-06 21:31:40 UTC
(In reply to Yaniv Kaul from comment #11)
> Duplicate of bug 1181665 ?
No.
This one is, in essence, about reaching an optimal size of the merged volume. That one is for deciding when the merge is done.

Comment 15 Ala Hino 2017-06-14 09:55:56 UTC
*** Bug 1420407 has been marked as a duplicate of this bug. ***

Comment 19 Allon Mureinik 2017-09-19 15:28:06 UTC
Ala - this is an impactful change.
Can you please add some doctext to it?

Comment 20 Ala Hino 2017-09-19 16:25:15 UTC
Added

Comment 23 Kevin Alon Goldblatt 2017-12-03 10:40:39 UTC
Verified with the following code:
--------------------------------------
ovirt-engine-4.2.0-0.5.master.el7.noarch
vdsm-4.20.8-53.gitc3edfc0.el7.centos.x86_64

Verified with the following scenario:
--------------------------------------
1. Created a VM with disks
2. Created a snapshot (lv size = 1g)
3. Wrote 1.1g of data and created snapshot2 (size = 2g)
4. Delete and live merge snapshot1 ( size = 1g)


Moving to VERIFIED

Comment 24 Sandro Bonazzola 2017-12-20 11:08:56 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.