Bug 1420407 - Live Merge: Reduce base volume size after live merge
Summary: Live Merge: Reduce base volume size after live merge
Keywords:
Status: CLOSED DUPLICATE of bug 1168327
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: 4.19.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.2.0
: ---
Assignee: Ala Hino
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 15:09 UTC by Ala Hino
Modified: 2017-06-14 09:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-14 09:55:56 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
rule-engine: exception+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 72670 0 master ABANDONED lvm: Add support to force reduce LV 2017-04-19 13:44:09 UTC
oVirt gerrit 72671 0 master ABANDONED live-merge: Shrink base Volume 2017-04-19 13:44:23 UTC

Description Ala Hino 2017-02-08 15:09:03 UTC
Description of problem:
During live merge, base volume size is extended to maximum, i.e. by top volume size + vol-chunk-size. This is a worst case calculation.
After live merge completes we have to reduce base volume size.

Steps to Reproduce:
1. Run live merge (make sure you copy some data to the top volume)
2.
3.

Actual results:
Base is extended by top's size

Expected results:
Base to be extend by data in top volume +/- 1gb

Comment 1 Nir Soffer 2017-02-22 19:54:33 UTC
This is too risky for 4.1, please reschedule this for 4.2.

Comment 2 Allon Mureinik 2017-04-23 15:47:03 UTC
The patches are abandoned, returning to NEW as a different solution should be designed.

Comment 3 Ala Hino 2017-06-14 09:55:56 UTC

*** This bug has been marked as a duplicate of bug 1168327 ***


Note You need to log in before you can comment on or make changes to this bug.