Bug 116843 - TB deviceconfig.py:160:hydrate:AttributeError: DevWireless instance has no attribute 'IPv6Init'
TB deviceconfig.py:160:hydrate:AttributeError: DevWireless instance has no at...
Status: CLOSED DUPLICATE of bug 116375
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-25 12:47 EST by Brian G. Anderson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2004-02-25 12:47:39 EST
Description of problem:
If I make a new "work" profile, copy a wireless device, and then try
and edit that device I get a python error

Also changing the wireless profile doesn't really take until you exit
the system-config-network and restart.


Version-Release number of selected component (if applicable):
system-config-network-1.3.15-1.1

How reproducible:
every time


Steps to Reproduce:
1.Create a new profile
2.Copy a device
3.select the copy and hit the edit button
  
Actual results:
Python stack dump


Expected results:
Edit panel for device


Additional info:
Even though the error is for a wireless device the same error will
occur when copying a ethernet device.

The stack is:
Component: system-config-network
Version: 1.3.15
Summary: TB33d3e349 deviceconfig.py:160:hydrate:AttributeError:
DevWireless instance has no attribute 'IPv6Init'
Traceback (most recent call last):
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 753, in on_editButton_clicked
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 844, in on_deviceEditButton_clicked
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/maindialog.py",
line 873, in editDevice
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/plugins/NCDevWireless.py",
line 41, in getDialog
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/wirelessconfig.py",
line 44, in __init__
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/deviceconfig.py",
line 81, in __init__
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/wirelessconfig.py",
line 71, in hydrate
  File
"/usr/src/build/350728-noarch/install/usr/share/system-config-network/netconfpkg/gui/deviceconfig.py",
line 160, in hydrate
AttributeError: DevWireless instance has no attribute 'IPv6Init'

Local variables in innermost frame:
widget: <gtk.Entry object (GtkEntry) at 0xb7aeef2c>
self: <netconfpkg.gui.wirelessconfig.wirelessConfigDialog instance at
0xb7ae888c>
Comment 1 Harald Hoyer 2004-02-26 03:36:34 EST

*** This bug has been marked as a duplicate of 116375 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:39 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.