Bug 1168576 - [RFE] Add support for qcow2 disks, adding the ability to choose qcow2 disk format when creating a template.
Summary: [RFE] Add support for qcow2 disks, adding the ability to choose qcow2 disk fo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Arik
QA Contact: Ori Gofen
URL:
Whiteboard:
Depends On:
Blocks: 1258911 1117219
TreeView+ depends on / blocked
 
Reported: 2014-11-27 10:35 UTC by Luca Miccini
Modified: 2019-07-11 08:24 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
When creating a template, users can now set the format of the template's disk volumes on creation. This enables users to define disks in the thin provisioning QCOW2 format.
Clone Of:
: 1271988 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:51:46 UTC
oVirt Team: Storage
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 38376 master MERGED core: configurable format and type for base volume of template Never
oVirt gerrit 38377 master MERGED webadmin: cow-sparse base volumes of templates Never
Red Hat Bugzilla 1271988 None None None Never

Internal Links: 1271988

Description Luca Miccini 2014-11-27 10:35:36 UTC
Description of problem:

Currently in RHEV-M we provide the ability to chose between two disk allocation policies: "Thin Provision" or "Preallocated".

Scope of this RFE is to request the ability to choose between raw-sparse and qcow2 in case "Thin Provision" is selected, and to make the full stack aware of the choice made.

Reason for this RFE is that creating a template from a vm using qcow2 disks or provisioning from existing templates takes a long time because of this "unawareness".

Version-Release number of selected component (if applicable):

3.4

How reproducible:

always

Steps to Reproduce:
1. Add a virtual Disk
2. select application policy "thin provision"
3. 

Actual results:

There is no control over which kind of thin provision disk is created.

Expected results:

Being able to decide between raw sparse and qcow2.

Additional info:

Comment 2 Allon Mureinik 2014-11-29 07:25:17 UTC
Sounds like a nit, let's re-review after handling bug 1142762

Comment 4 Arik 2015-03-01 16:11:25 UTC
According to ImagesHandler#checkImageConfiguration, we don't support the following configuration:
storageDomain.getStorageType().isBlockDomain() && volumeType == VolumeType.Sparse && volumeFormat == VolumeFormat.RAW

So should we drop this check or should we present the option of raw-sparse only for file-domains?

Comment 5 Allon Mureinik 2015-03-01 16:27:45 UTC
(In reply to Arik from comment #4)
> According to ImagesHandler#checkImageConfiguration, we don't support the
> following configuration:
> storageDomain.getStorageType().isBlockDomain() && volumeType ==
> VolumeType.Sparse && volumeFormat == VolumeFormat.RAW
> 
> So should we drop this check or should we present the option of raw-sparse
> only for file-domains?
Raw-sparse isn't support on block domain in the storage level - don't remove it :-)

This RFE is about ADDING the ability to have the base volume cow-sparse when creating a template.

Comment 6 Arik 2015-03-01 17:49:14 UTC
(In reply to Allon Mureinik from comment #5)
If I understand the code correctly, we currently provide only two options: preallocated and thin provision.
On file-based domains thin provisioning is mapped to sparse+raw and on block based storage it is mapped to sparse+cow.

At the beginning I thought that we're asked to provide 3 options (for every storage type):
1. preallocated
2. thin provision (cow)
3. thin provision (raw)

But since raw-sparse is not supported on block domain, we just need to provide the option for cow-spase for file-domain? Or my observation of the current state is wrong?

Comment 7 Allon Mureinik 2015-03-01 17:57:11 UTC
On file domains, raw+preallocated doesn't make any sense for a template (it's not as though it's going to grow), and moreover, any half decent file system will just ignore the preallocation request.

I think we should remove the notion of having the user choose thin vs. preallocated, and just have them choose the format.

QCow always implies SPRASE.
RAW on file implies SPARSE, while RAW on block implies PREALLOCATED.

Comment 9 Max Kovgan 2015-06-28 14:13:36 UTC
ovirt-3.6.0-3 release

Comment 10 Aharon Canan 2015-07-08 08:06:30 UTC
From the description - 
"Scope of this RFE is to request the ability to choose between raw-sparse and qcow2 in case "Thin Provision" is selected, and to make the full stack aware of the choice made."

From comment #5 - 
"This RFE is about ADDING the ability to have the base volume cow-sparse when creating a template."

This comment is based on one simple use case that was givenas an example in the description.
I think we should make the changes all over, this is the original request.
Taking RFE and marking it as fixed while fixing only single use case is mistake.

Yaniv, please advice here.

in case we will go with current, we will mark it as verified and will open the same RFE for fixing all other place.

Comment 11 Allon Mureinik 2015-07-08 10:44:03 UTC
(In reply to Aharon Canan from comment #10)
> This comment is based on one simple use case that was givenas an example in
> the description.
> I think we should make the changes all over, this is the original request.
> Taking RFE and marking it as fixed while fixing only single use case is
> mistake.
No, that's called SCOPING.

> in case we will go with current, we will mark it as verified and will open
> the same RFE for fixing all other place.
Please do.

Comment 12 Aharon Canan 2015-07-08 10:58:31 UTC
I think different than you. 

Yaniv, as you are the PM and the one who represent the costumers needs, your call.

Comment 32 Yaniv Lavi 2015-10-15 08:49:07 UTC
I have created a RFE for create VM from template and Tim created a separate RFe for his use case. Please verify the current RFE on creating a template.

Comment 33 Aharon Canan 2015-11-01 16:14:34 UTC
Following comment #31 - scenario was tested and passed (comment #8)

Verified.

Comment 34 Allon Mureinik 2016-01-19 09:55:25 UTC
Arik, can you please add some doctext to this RFE? Thanks!

Comment 38 errata-xmlrpc 2016-03-09 20:51:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.