Bug 1271988 - [RFE] Add support for qcow2 disks, adding the ability to choose qcow2 disk format when creating a VM from template.
[RFE] Add support for qcow2 disks, adding the ability to choose qcow2 disk fo...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.6.0
All Linux
medium Severity medium
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Fred Rolland
Elad
: FutureFeature
Depends On: 1317453
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 04:46 EDT by Yaniv Lavi
Modified: 2016-08-23 16:30 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
When creating a virtual machine from a template, the user is able to choose the format of the disks: either RAW or QCOW2. The Allocation Policy section is now hidden. If the Template Provisioning is Thin, the format of the disks will be marked as QCOW2 and the user won't be able to change it. If the Template Provisioning is Clone, the user will be able to select either QCOW2 or RAW.
Story Points: ---
Clone Of: 1168576
: 1317453 (view as bug list)
Environment:
Last Closed: 2016-08-23 16:30:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
acanan: testing_plan_complete?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 57190 master NEW webadmin: Disk format on add VM from template 2016-05-09 07:58 EDT

  None (edit)
Comment 3 Yaniv Kaul 2016-03-03 09:56:33 EST
Isn't it exactly the opposite of bug 1097843 ?
Comment 4 Allon Mureinik 2016-03-06 03:45:22 EST
(In reply to Yaniv Kaul from comment #3)
> Isn't it exactly the opposite of bug 1097843 ?
No.
The format I(QCOW vs. raw) is something an admin can make an informed decision about. Thew allocation policy is a fallacy, as it's completely coupled to the combination of foramt+storage type.
Comment 5 Elad 2016-07-13 10:17:23 EDT
Executed the feature basic flows after setup upgrade (3.6 -> 4.0):

https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/testrun?id=4_0_Storage_Ability_to_change_disk_interface_for_a_VM_disk_run_31_06_2016

Tested using Webadmin, All passed. 

Note that for REST API, we're still block due to:
Bug 1352657 - GET of diskattachment returns a list of objects without the href property


Tested using:
rhevm-4.0.0.6-0.1.el7ev.noarch
vdsm-4.18.4-2.el7ev.x86_64
libvirt-daemon-1.2.17-13.el7_2.5.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.18.x86_64
Comment 6 Elad 2016-07-14 03:11:50 EDT
I accidentally verified this bug. Moving back to ON_QA
Comment 7 Elad 2016-07-24 07:12:31 EDT
Executed according to the following Polarion test run:

https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/testrun?id=4_0_Storage_Ability_to_choose_qcow2_disk_format_when_creating_a_VM_from_%20template_run_19_07_2016

Moving to VERIFIED.

Tested using:
rhevm-4.0.1.1-0.1.el7ev.noarch
vdsm-4.18.5.1-1.el7ev.x86_64
Comment 9 errata-xmlrpc 2016-08-23 16:30:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html

Note You need to log in before you can comment on or make changes to this bug.