Bug 1168601 - The progress bar still exists in Hosted Engine page after finish downloading ISO/OVA file
Summary: The progress bar still exists in Hosted Engine page after finish downloading ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine
Version: 3.4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Ryan Barry
QA Contact: wanghui
URL:
Whiteboard:
Depends On:
Blocks: 1059435 rhevh-7.0 1198658 1250199
TreeView+ depends on / blocked
 
Reported: 2014-11-27 11:35 UTC by wanghui
Modified: 2016-03-09 14:23 UTC (History)
7 users (show)

Fixed In Version: ovirt-node-plugin-hosted-engine-0.3.0-1.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1198658 (view as bug list)
Environment:
Last Closed: 2016-03-09 14:23:22 UTC
oVirt Team: Node
Target Upstream Version:
ylavi: Triaged+


Attachments (Terms of Use)
hosted_engine_1.JPG (2.02 MB, image/jpeg)
2014-11-27 11:35 UTC, wanghui
no flags Details
hosted_engine_2.JPG (2.10 MB, image/jpeg)
2014-11-27 11:36 UTC, wanghui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 36132 master MERGED Clear the download progressbar and text once we're finished Never
oVirt gerrit 38217 ovirt-3.5 MERGED Clear the download progressbar and text once we're finished Never

Description wanghui 2014-11-27 11:35:46 UTC
Created attachment 961989 [details]
hosted_engine_1.JPG

Description of problem:
The progress bar still exists in Hosted Engine page after finish downloading ISO/OVA file as hosted_engine_2.JPG shows. It should be removed after we finish downloading the files.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20141126.0.iso
ovirt-node-3.1.0-0.28.20141126git25ce016.el7
ovirt-node-plugin-hosted-engine-0.2.0-4.0.el7ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Clear install rhev-hypervisor7-7.0-20141126.0.iso.
2. Enabled Network.
3. File a reachable iso in Engine ISO/OVA Path.
4. After finish downloading, click <Cancel> when prompt "Begin Hosted Engine Setup".
5. Move curse to RHEVM page and back to Hosted Engine page.
6. Logoff rhevh and login again.

Actual results:
1. After step4, it return to Hosted Engine page with 100% shows in progress bar as hosted_engine_1.JPG shows.
2. After step5, it return to Hosted Engine page with 0% shows in progress bar as hosted_engine_2.JPG shows.
3. After step6, the progress bar in Hosted Engine page disappeared.

Expected results:
1. After step4, the progress bar should be removed from Hosted Engine page.

Additional info:

Comment 1 wanghui 2014-11-27 11:36:46 UTC
Created attachment 961990 [details]
hosted_engine_2.JPG

Comment 5 wanghui 2015-11-27 04:15:49 UTC
Test version:
rhev-hypervisor7-7.2-20151112.1.el7ev
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch
ovirt-node-plugin-hosted-engine-0.3.0-3.el7ev.noarch

Test steps:
1. Clear install rhev-hypervisor7-7.2-20151112.1.el7ev.
2. Enabled Network.
3. File a reachable iso in Engine ISO/OVA Path.
4. After finish downloading, click <Cancel> when prompt "Begin Hosted Engine Setup".
5. Move curse to RHEVM page and back to Hosted Engine page.
6. Logoff rhevh and login again.

Test result:
1. No progress bar exists once the downloading finished.

So this issue is fixed in ovirt-node-plugin-hosted-engine-0.3.0-3.el7ev.noarch. Change the status to verified.

Comment 7 errata-xmlrpc 2016-03-09 14:23:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.