Bug 1250199 - PRD35 - [RFE] RHEVM Self Hosted Engine on RHEV-H
PRD35 - [RFE] RHEVM Self Hosted Engine on RHEV-H
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.3.0
All Linux
medium Severity medium
: ---
: 3.5.4
Assigned To: Balakrishnan, Radhesh
Nikolai Sednev
node
: FutureFeature, Reopened, TestOnly, Tracking, ZStream
: 1059435 (view as bug list)
Depends On: 1059435 1094842 rebase-ovirt-node-3.1 1139019 1139020 1144917 1151342 1151347 1159166 1168486 1168601 1171614 1172061 1200474 1204470 1205225 1206884 1208780 1209861 1218634 1230096 1230614 1230638 1231614 1235350 1235591 1236518 1239285 1241470 1244636 1244740 1245143 1251827 1251912 1252796 1254185 1254523 1254888 1254926
Blocks: 1123938 1241478
  Show dependency treegraph
 
Reported: 2015-08-04 13:51 EDT by Eyal Edri
Modified: 2016-02-29 11:01 EST (History)
31 users (show)

See Also:
Fixed In Version: vt16.6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1059435
Environment:
Last Closed: 2015-09-03 13:27:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 875583 None None None Never
oVirt gerrit 39819 None None None Never

  None (edit)
Comment 1 Eyal Edri 2015-08-04 16:44:30 EDT
*** Bug 1059435 has been marked as a duplicate of this bug. ***
Comment 2 Eyal Edri 2015-08-04 16:46:04 EDT
bug was cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1059435
which was already included in previous errata that was shipped live.

in order to include this in 3.5.4 errata, a new bug had to be created,
hence this clone.

yaniv, can you PM_ACK?
we will need the 3.5.z flag as well.
Comment 3 Artyom 2015-08-11 03:05:47 EDT
hosted engine HA test(include global, local maintenance and start of HE vm on second host because crush of engine, crush of host network...) pass on:

Red Hat Enterprise Virtualization Hypervisor release 7.1 (20150805.0.el7ev) - PASS

Red Hat Enterprise Virtualization Hypervisor release 6.7 (20150804.0.el6ev) - PASS

under NFS storage
Comment 4 Elad 2015-08-11 04:27:15 EDT
Hosted-engine deployment and HA (additional host) over iSCSI (includes migration of the HA VM) succeeded using both:


Red Hat Enterprise Virtualization Hypervisor release 7.1 (20150805.0.el7ev)

Red Hat Enterprise Virtualization Hypervisor release 6.7 (20150804.0.el6ev)
Comment 5 Nikolai Sednev 2015-08-31 05:47:45 EDT
HE deployment on RHEVH6.7 (20150828.0.el6ev) succeeded:
Works for me on these components:
vdsm-4.16.26-1.el6ev.x86_64
sanlock-2.8-2.el6_5.x86_64
libvirt-client-0.10.2-54.el6.x86_64
mom-0.4.1-5.el6ev.noarch
qemu-kvm-rhev-0.12.1.2-2.479.el6.x86_64
ovirt-hosted-engine-setup-1.2.5.3-1.el6ev.noarch
ovirt-hosted-engine-ha-1.2.6-3.el6ev.noarch
Red Hat Enterprise Virtualization Hypervisor release 6.7 (20150828.0.el6ev)


Engine:
rhevm-3.5.4.2-1.3.el6ev.noarch
rhevm-setup-3.5.4.2-1.3.el6ev.noarch
rhevm-guest-agent-common-1.0.10-2.el6ev.noarch
Linux version 2.6.32-573.3.1.el6.x86_64 (mockbuild@x86-029.build.eng.bos.redhat.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-16) (GCC) ) #1 SMP Mon Aug 10 09:44:54 EDT 2015

Deployment was tested via TUI and CLI both, on NFS3.
Comment 6 Elad 2015-08-31 05:51:14 EDT
Using iSCSI, HE deployment of second host failed. Reported here 1258399

Red Hat Enterprise Virtualization Hypervisor release 6.7 (20150828.0.el6ev)
Comment 7 Nikolai Sednev 2015-08-31 09:53:05 EDT
HE deployment on RHEVH7.1 (20150827.1.el7ev) succeeded:
Works for me on these components:
libvirt-client-1.2.8-16.el7_1.3.x86_64
mom-0.4.1-5.el7ev.noarch
qemu-kvm-rhev-2.1.2-23.el7_1.8.x86_64
vdsm-4.16.26-1.el7ev.x86_64
ovirt-hosted-engine-setup-1.2.5.3-1.el7ev.noarch
sanlock-3.2.2-2.el7.x86_64
Red Hat Enterprise Virtualization Hypervisor release 7.1 (20150827.1.el7ev)

Engine:
Linux version 2.6.32-573.3.1.el6.x86_64 (mockbuild@x86-029.build.eng.bos.redhat.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-16) (GCC) ) #1 SMP Mon Aug 10 09:44:54 EDT 2015
rhevm-3.5.4.2-1.3.el6ev.noarch
rhevm-guest-agent-common-1.0.10-2.el6ev.noarch

Deployment was tested via TUI and CLI both, on NFS3, setup included 2 hosts.
Comment 8 Artyom 2015-09-01 02:54:05 EDT
Hosted-engine HA test on NFS storage passed ob both builds:
Red Hat Enterprise Virtualization Hypervisor release 6.7 (20150828.0.el6ev)
Red Hat Enterprise Virtualization Hypervisor release 7.1 (20150827.1.el7ev)
Comment 9 Nikolai Sednev 2015-09-01 03:45:54 EDT
Hi Elad,
Can you rerun the iSCSI tests for RHEVH6.7 in case that that you had incorrect hostname on RHEVH6.7? It might appear that your host's FQDN wasn't set as it's real hostname at /etc/sysconfig/network file and you couldn't establish proper connectivity between the storage and the host?
Comment 10 Elad 2015-09-01 04:08:53 EDT
I had a network issue with the second host (RHEV-H) I tried to deploy hosted-engine on, its hostname was the same as the first host. 
I fixed that and tested again the scenario using cleanly installed RHEV-H,  couldn't reproduce. (RHEV-H 6.7)
Comment 11 Gil Klein 2015-09-02 03:17:16 EDT
Hosted-engine HA + deployment testing on iSCSI + NFS and vlan/bond has passed on:
Red Hat Enterprise Virtualization Hypervisor release 6.7 (20150828.0.el6ev)
Red Hat Enterprise Virtualization Hypervisor release 7.1 (20150827.1.el7ev)
Comment 13 errata-xmlrpc 2015-09-03 13:27:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1725.html

Note You need to log in before you can comment on or make changes to this bug.