Bug 1168689 - Upgrading from 3.4.4 to 3.5.1 snapshot the vdsm rpm throw an exception
Summary: Upgrading from 3.4.4 to 3.5.1 snapshot the vdsm rpm throw an exception
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.1
Assignee: Yaniv Bronhaim
QA Contact: Gil Klein
URL:
Whiteboard: infra
: 1168203 (view as bug list)
Depends On:
Blocks: oVirt_3.5.1_tracker rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-11-27 15:35 UTC by Sandro Bonazzola
Modified: 2016-02-10 19:32 UTC (History)
13 users (show)

Fixed In Version: av13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-21 16:03:52 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 35739 master MERGED Fixed %post script error during upgrade Never
oVirt gerrit 35744 ovirt-3.5 MERGED Fixed %post script error during upgrade Never
oVirt gerrit 35765 None None None Never

Description Sandro Bonazzola 2014-11-27 15:35:44 UTC
Description of problem:
Upgrading from 3.4.4 to 3.5.1 snapshot the vdsm rpm throw an exception:

warning: /etc/vdsm/vdsm.conf created as /etc/vdsm/vdsm.conf.rpmnew
Traceback (most recent call last):
  File "/usr/bin/vdsm-tool", line 224, in <module>
    sys.exit(main())
  File "/usr/bin/vdsm-tool", line 210, in main
    except vdsm.tool.UsageError as e:
AttributeError: 'module' object has no attribute 'UsageError'

Version-Release number of selected component (if applicable):
Upgrading to:
 vdsm-4.16.7-71.gitc3ea4d5.el6.x86_64
From:
  vdsm-4.14.17-0.el6.x86_64


How reproducible:
100%

Comment 1 Dan Kenigsberg 2014-11-27 16:24:25 UTC
dup of gug 1168203 ?

Comment 2 Yaniv Bronhaim 2014-11-27 18:33:37 UTC
look like that.. weird. probably configure sanlock throws exception on rhel7? we hide such errors

Comment 3 Sandro Bonazzola 2014-11-28 10:26:07 UTC
(In reply to Yaniv Bronhaim from comment #2)
> look like that.. weird. probably configure sanlock throws exception on
> rhel7? we hide such errors

Please note here I was using CentOS 6.6.

Comment 4 Sandro Bonazzola 2014-11-28 10:40:36 UTC
It's 100% reproducible also on Fedora 20.

Comment 5 Yaniv Bronhaim 2014-11-30 14:40:06 UTC
It doesn't block anything. it just an exception that should hide or not thrown at all. we will check why it appears and will fix it for next build

Comment 6 Yaniv Bronhaim 2014-11-30 14:41:13 UTC
*** Bug 1168203 has been marked as a duplicate of this bug. ***

Comment 7 Yaniv Bronhaim 2014-12-01 09:39:25 UTC
Apparently it does important as it doesn't run the rest of the %post script which is important for valid vdsm run (such as restarting the service)

Comment 8 Yaniv Bronhaim 2014-12-04 09:21:35 UTC
*** Bug 1169364 has been marked as a duplicate of this bug. ***

Comment 9 Sandro Bonazzola 2015-01-21 16:03:52 UTC
oVirt 3.5.1 has been released. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.