Bug 1168819 - [USS]: Need defined rules for snapshot-directory, setting to a/b works but in linux a/b is b is subdirectory of a
Summary: [USS]: Need defined rules for snapshot-directory, setting to a/b works but in...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Manikandan
QA Contact:
URL:
Whiteboard: USS
Depends On: 1163736 1304282
Blocks: 1166590 1305868
TreeView+ depends on / blocked
 
Reported: 2014-11-28 07:14 UTC by Vijaikumar Mallikarjuna
Modified: 2016-06-16 12:40 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1163736
: 1305868 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:40:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-11-28 07:16:59 UTC
REVIEW: http://review.gluster.org/9209 (gluster/uss: Validate USS volume set options) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 2 Anand Avati 2014-11-28 07:19:15 UTC
REVIEW: http://review.gluster.org/9209 (gluster/uss: Validate USS volume set options) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 3 Anand Avati 2014-12-02 06:29:39 UTC
REVIEW: http://review.gluster.org/9209 (gluster/uss: Validate USS volume set options) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 4 Anand Avati 2014-12-03 07:00:58 UTC
REVIEW: http://review.gluster.org/9209 (gluster/uss: Validate USS volume set options) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 5 Anand Avati 2014-12-03 11:43:12 UTC
REVIEW: http://review.gluster.org/9209 (gluster/uss: Validate USS volume set options) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 6 Anand Avati 2014-12-12 06:34:00 UTC
REVIEW: http://review.gluster.org/9209 (gluster/uss: Validate USS volume set options) posted (#6) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 7 Anand Avati 2014-12-12 11:54:59 UTC
REVIEW: http://review.gluster.org/9209 (gluster/uss: Validate USS volume set options) posted (#7) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 8 Anand Avati 2014-12-18 09:18:36 UTC
REVIEW: http://review.gluster.org/9209 (gluster/uss: Validate USS volume set options) posted (#8) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 9 Vijay Bellur 2016-02-03 09:04:28 UTC
REVIEW: http://review.gluster.org/9209 (uss: validate USS option features.snapshot-directory) posted (#9) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 10 Vijay Bellur 2016-02-03 09:46:05 UTC
REVIEW: http://review.gluster.org/9209 (uss: validate USS option features.snapshot-directory) posted (#10) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 11 Vijay Bellur 2016-02-03 10:02:48 UTC
REVIEW: http://review.gluster.org/9209 (uss: validate USS option features.snapshot-directory) posted (#11) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 12 Vijay Bellur 2016-02-04 06:45:54 UTC
REVIEW: http://review.gluster.org/9209 (uss: validate USS option features.snapshot-directory) posted (#12) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 13 Vijay Bellur 2016-02-05 07:26:19 UTC
REVIEW: http://review.gluster.org/9209 (uss: validate USS option features.snapshot-directory) posted (#13) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

Comment 14 Vijay Bellur 2016-02-09 12:34:37 UTC
COMMIT: http://review.gluster.org/9209 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 501a31eadbce8cfe9ec0ed149bafc8fa6460ff9a
Author: vmallika <vmallika@redhat.com>
Date:   Wed Feb 3 14:32:17 2016 +0530

    uss: validate USS option features.snapshot-directory
    
    USS option features.snapshot-directory
       contains only 'alphanum, -, _, .'
       starts with dot (.)
       value cannot exceed 255 characters
    and throws error for any other argument.
    
    Change-Id: Iad64635206ddf5599351020d99aafb3dd9d17bc1
    BUG: 1168819
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/9209
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 17 Niels de Vos 2016-06-16 12:40:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.