Bug 1305868 - [USS]: Need defined rules for snapshot-directory, setting to a/b works but in linux a/b is b is subdirectory of a
[USS]: Need defined rules for snapshot-directory, setting to a/b works but in...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
3.7.7
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
USS
: ZStream
Depends On: 1163736 1168819 1304282
Blocks: 1166590
  Show dependency treegraph
 
Reported: 2016-02-09 07:37 EST by Vijaikumar Mallikarjuna
Modified: 2016-04-19 03:25 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1168819
Environment:
Last Closed: 2016-04-19 03:25:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-09 07:43:58 EST
REVIEW: http://review.gluster.org/13409 (uss: validate USS option features.snapshot-directory) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2016-02-09 07:44:40 EST
REVIEW: http://review.gluster.org/13409 (uss: validate USS option features.snapshot-directory) posted (#2) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2016-02-15 03:24:38 EST
COMMIT: http://review.gluster.org/13409 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit fa3df1f5eaf3104c0eb597b954dd17b1a067db8c
Author: vmallika <vmallika@redhat.com>
Date:   Tue Feb 9 18:11:24 2016 +0530

    uss: validate USS option features.snapshot-directory
    
    This is a backport of http://review.gluster.org/#/c/9209
    
    USS option features.snapshot-directory
       contains only 'alphanum, -, _, .'
       starts with dot (.)
       value cannot exceed 255 characters
    and throws error for any other argument.
    
    > Change-Id: Iad64635206ddf5599351020d99aafb3dd9d17bc1
    > BUG: 1168819
    > Signed-off-by: vmallika <vmallika@redhat.com>
    > Reviewed-on: http://review.gluster.org/9209
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    > Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    > Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    
    Change-Id: I1b85d6851a223b51714c0498b457c41db99f5f58
    BUG: 1305868
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13409
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 4 Kaushal 2016-04-19 03:25:16 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.