Bug 116895 - mod_probe -- ide-cd. error
mod_probe -- ide-cd. error
Status: CLOSED DUPLICATE of bug 116622
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-25 20:35 EST by Dan Kelley
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Kelley 2004-02-25 20:35:54 EST
Description of problem:

I cannot use the cdrom, and I'm not entirely sure why.  I'll describe
the symptoms and what I've tried.

First off, it does not automount.

Secondly, I cannot do "mount" e.g. 

$ mount /mnt/cdrom
ount: /dev/cdrom is not a valid block device

with setup

$ grep cdrom /etc/fstab
/dev/cdrom              /mnt/cdrom              udf,iso9660
noauto,owner,kudzu,ro 0 0


Thirdly, I see the following output from dmesg:

request_module: failed /sbin/modprobe -- ide-cd. error = 256

In case it's relevant, here is info on the kernel:
[root@kelley-home kelley]# grep kernel /boot/grub/menu.lst
#          all kernel and initrd paths are relative to /boot/, eg.
#          kernel /vmlinuz-version ro root=/dev/hda3
        kernel /vmlinuz-2.6.1-1.65 ro root=LABEL=/ hdc=ide-scsi



(end of problem-description content)



Version-Release number of selected component (if applicable):

I don't know, really, what component is problematic.  I'm running
Fedora Core 2 test 1.

How reproducible:

Always.

Steps to Reproduce:
1. boot up
2. try above-named steps
3.
  
Actual results:

Cannot use cdrom

Expected results:

Can use cdrom

Additional info:

I looked around for other advice on this, but couldn't find any, so I
thought it would be Ok to report it here, even though I wasn't sure
under which component to file the bug (the "cdr" as the component was
just the closest I could find, since the system demands a guess).

Thanks.
Comment 1 Alexander Farley 2004-02-25 22:55:43 EST
I do not think that the ide-scsi entry is needed anymore since scsi
emulation has been depracated with the 2.6.x kernels. I solved this
problem by simply eliminating the hdc=ide-scsi entry in grub.conf. I
think that the problem with this is that whatever program is writing
to the grub.conf file when installing a new kernel, allows the new
kernel to inherit the previous kernel's switches. However, in this
case the switch is no longer useful and causes problems.
Comment 2 Bill Nottingham 2004-02-25 23:40:11 EST
Remove the hdc=ide-scsi, yes.

*** This bug has been marked as a duplicate of 116622 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:39 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.