Bug 116945 - Unable to see newly created LUNs without a reboot.
Summary: Unable to see newly created LUNs without a reboot.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tom Coughlan
QA Contact:
URL:
Whiteboard:
Keywords:
: 116854 116950 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-26 17:49 UTC by Matthew Hanley
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 17:53:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Hanley 2004-02-26 17:49:10 UTC
Description of problem:

We have a Dell server with a Qlogic Fibre card connected to a SAN. 
It's not possible to see newly created LUNs without rebooting the server.

The same machine, running Windows, can see new LUNs on the fly. (As
can Solaris).

RedHat support ticket #285474 suggested going here and opening a ticket.

Comment 1 Elliot Lee 2004-03-01 18:06:00 UTC
*** Bug 116854 has been marked as a duplicate of this bug. ***

Comment 2 Elliot Lee 2004-03-01 18:06:33 UTC
*** Bug 116950 has been marked as a duplicate of this bug. ***

Comment 4 Tom Coughlan 2004-03-23 20:52:57 UTC
The hot-plug infrastructure in the 2.6 kernel may provide the ability
to do this on the fly in the future.  For 2.4, some manual
intervention is needed.

The big hammer, of course, is to rmmod/modprobe the QLogic driver.
When this is not a viable solution, the Qlogic driver that is coming
in the RHEL 3 U2 update provides a less disruptive solution:

/*
 * Usage: echo "scsi-qlascan " > /proc/scsi/<driver-name>/<adapter-id>
 *
 * <driver-name> can be either one : qla2100/qla2200/qla2300
 *
 * Ex:- For qla2300 driver:
 *      echo "scsi-qlascan " > /proc/scsi/qla2300/<adapter-id>
 *
 * <adapter-id> is the instance number of the HBA.
 *
 * Scan for all luns on all ports.
 */

After you do this, you need to make the SCSI midlayer re-scan:

$ echo "scsi-add-single-device a b c d" > /proc/scsi/scsi
# a is controller number
# b is bus number
# c is id number
# d is lun number

There is a script www.garloff.de/kurt/linux/rescan-scsi-bus.sh
that you can use to scan through a range of SCSI addresses if you want.

Let us know if this is adequate. Also, try the U2 beta (coming soon),
and let us know the results. 
 

Comment 5 Steven Scoleri 2004-07-22 14:18:00 UTC
the rescan-scsi-bus.sh doesn't seem to work for the qla2300 in redhat 
3

Comment 6 Tom Coughlan 2004-07-22 15:41:09 UTC
What is your kernel version and QLogic driver version?  

Please post /var/log/messages showing boot mesages, and any messages
when you did the echos to /proc.

Comment 7 Tom Coughlan 2004-12-21 22:38:38 UTC
This has been NEEDINFO for 5 months.  Are you still having a problem
with the manual scan procedure described above? Please re-test with
Update 4 and post the requested log information here.

Comment 8 Matthew Hanley 2005-01-13 16:55:53 UTC
Sorry. . .must have missed the email for the NEEDINFO.

Unfortunately, I won't be able to give a hand with this anymore - we 
installed Polyserve's clustering file system with uses its own qlogic 
driver and patches to the kernel.

As a result, the scsi-qlascan works like a charm now.  Not sure you 
want to contact Polyserve for the specifics, but they are very 
helpful. 

Comment 9 Tom Coughlan 2005-01-13 17:53:08 UTC
The QLogic driver was updated in U4. Please re-open this bug if the
function is not working in U4. 


Note You need to log in before you can comment on or make changes to this bug.