Bug 11698 - can't specify "--ondisk" info within kickstart for cpqarray
Summary: can't specify "--ondisk" info within kickstart for cpqarray
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
: 20221 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-26 21:59 UTC by bruno
Modified: 2007-03-27 03:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-31 06:40:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bruno 2000-05-26 21:59:37 UTC
on our compaq DL380, we have two raid devices: ida/c0d0 and ida/c0d1
which can be accessed through the 'cpqarray' driver.

we're trying to develop an "unattended kickstart configuration", for the
machine, that is, we want red hat to install with no interactive entries
required.

kickstart will run unattended if we define the partition info as:

	part swap --size 128
	part / --size 1000 --grow

but, this puts "/" on ida/c0d0 and "swap" on ida/c0d1. we'd like to put
both "/" and "swap" on the same disk (e.g., ida/c0d0). but when we
specify the partition info to be:

	part swap --size 128 --ondisk ida/c0d0
	part / --size 1000 --grow --ondisk ida/c0d0

kickstart drops into interactive mode.

Comment 1 Michael Fulbright 2000-06-09 20:30:09 UTC
Passed to QA to verify.

Comment 2 Brock Organ 2000-11-03 14:09:50 UTC
verified this behavior is present in 7 as well ... thanks for your report!

Comment 3 Brock Organ 2000-11-06 20:13:31 UTC
*** Bug 20221 has been marked as a duplicate of this bug. ***

Comment 4 Steven Roberts 2001-02-05 07:27:42 UTC
FYI.  this also causes problems on VA linux boxes (using the Mylex RAID controller).

we have rd/c0d0, rd/c0d1 (and sometimes a rd/c0d2)

same thing, puts partitions on the wrong disks, and drops into interactive mode

Comment 5 Matt Wilson 2001-03-29 23:27:37 UTC
please try "--ondisk c0d0p" as a workaround.


Comment 6 Matt Wilson 2001-03-30 02:15:40 UTC
rather "--ondisk ida/c0d0p"


Comment 7 Steven Roberts 2001-03-31 06:40:25 UTC
the workaround worked for me.  I have Mylex controllers, so used "--ondisk rd/c0d0p".  Still can't get more than 4 partitions on one drive with a RAID 
controller though (with or without specifying --ondisk).  I have a few boxes I can help debug the problem on, so if you have patches you need tested, 
please let me know.  Also if you could point me to the spot in anaconda doing the partition creation I can help look through the code.


Note You need to log in before you can comment on or make changes to this bug.