Bug 20221 - kickstart "part" config and hardware RAID devices
Summary: kickstart "part" config and hardware RAID devices
Status: CLOSED DUPLICATE of bug 11698
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brock Organ
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-02 16:29 UTC by rmharwood
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-06 20:13:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description rmharwood 2000-11-02 16:29:13 UTC
Inside a kickstart config file, under the "part" section, the "--ondisk"
option does not seem to work with hardware RAID logical volumes, namely
/dev/ida/c?d? (this is on a Compaq DL380).

For example, I'd like to run with the following kickstart config:

	part / --size 2048 --ondisk ida/c0d0
	part /var --size 1024 --ondisk ida/c0d0
	part swap --size 384 --ondisk ida/c0d0
	part /usr/local --size 1024 --grow  --ondisk ida/c0d0
	part /data --size 2048 --grow --ondisk ida/c0d1

but this does not work. Instead of an automatic installation, the config
drops into the diskdruid screen for partitioning. If the "--ondisk" options
are left off then partitioning does occur, but not with the desired
physical layout.

I've tried replacing ida/c0d0 with /dev/ida/c0d0 and it makes no
difference.

Comment 1 Michael Fulbright 2000-11-03 20:00:52 UTC
Passed to QA for verification.

Comment 2 Brock Organ 2000-11-06 20:13:34 UTC
thanks for your report!  This issue is one we hope to resolve ... :)

*** This bug has been marked as a duplicate of 11698 ***


Note You need to log in before you can comment on or make changes to this bug.