Bug 117004 - samba-common: smb.conf man page truncated
Summary: samba-common: smb.conf man page truncated
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 117051 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-27 10:28 UTC by Tomasz Ostrowski
Modified: 2014-08-31 23:25 UTC (History)
2 users (show)

Fixed In Version: samba-3.0.4-1.FC1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 17:44:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomasz Ostrowski 2004-02-27 10:28:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
smb.conf man page is truncated. The last paragraph seen is:

---
The following sample section defines a file space share. The  user  has
write access to the path /home/bar. The share is accessed via the share
name ``foo'': Example
---

And nothing more. And there should be a lot more, as can be seen in
/usr/share/doc/samba-3.0.2/docs/htmldocs/smb.conf.5.html


Version-Release number of selected component (if applicable):
samba-common-3.0.2-7.FC1

How reproducible:
Always

Steps to Reproduce:
1. man smb.conf
2. [End]


Actual Results:  Fragment of the man page seen, ending with:
The following sample section defines a file space share. The user has
write access to the path /home/bar. The share is accessed via the
share name ``foo'': Example


Expected Results:  The whole man page seen, ending with:
The  original  Samba  man  pages  were  written  by  Karl Auer. The
man page sources were converted  to  YODL format (another excellent
piece of Open Source software, available at
ftp://ftp.icce.rug.nl/pub/unix/) and updated for the Samba 2.0 release
by Jeremy Allison. The  conversion  to  DocBook  for  Samba 2.2 was
done by Gerald Carter. The conversion to DocBook XML 4.2 for Samba 3.0
was done by Alexander Bokovoy.


Additional info:

I use the following locale settings:
LANG=en_US
LC_CTYPE=pl_PL.iso88592
LC_COLLATE=pl_PL.iso88592

I also tried the settings:
LANG=en_US
LC_CTYPE=en-US.utf8
I didn't work either.

Workaround:
Use HTML documentation
/usr/share/doc/samba-3.0.2/docs/htmldocs/smb.conf.5.html

It is also possible that it is a man bug.

Comment 1 Jay Fenlason 2004-02-27 19:39:30 UTC
*** Bug 117051 has been marked as a duplicate of this bug. ***

Comment 2 Tomasz Ostrowski 2004-02-28 12:27:40 UTC
It looks that it is caused by non-utf-8 locale settings:
LC_CTYPE="en_US.UTF-8" man smb.conf
  - everything is fine
LC_CTYPE="en_US" man smb.conf
  - man truncated


Comment 3 Tomasz Ostrowski 2004-02-28 13:15:41 UTC
It looks like it is samba error. The man pages are supposed to be in
UTF-8 encoding but it uses character 160 (non-break space in
iso-8859-X encodings) on which chokes iconv, which is used in nroff
script when locale is not set to utf-8.

Comment 4 Tomasz Ostrowski 2004-10-19 17:19:41 UTC
Seems that this bug is corrected with errata packages - I can not
reproduce this with samba-common-3.0.7-2.FC1 from FC1 updates nor with
samba-common-3.0.8-0.pre1 from FC3test3.

Please close this bug then.

Comment 5 Jay Fenlason 2004-10-19 17:44:35 UTC
It's fixed in 3.0.4-1.FC1 and later.  I guess this bug slipped 
through the cracks. 


Note You need to log in before you can comment on or make changes to this bug.