Bug 117013 - Installer kernel sbp2 module can't find CD on Dell X200
Installer kernel sbp2 module can't find CD on Dell X200
Status: CLOSED DUPLICATE of bug 77259
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-27 09:01 EST by Marty Shannon
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marty Shannon 2004-02-27 09:01:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2)
Gecko/20030708

Description of problem:
Laptop boots install CD fine; kernel loads & installer starts;
ultimately, it asks what medium the installation is coming from, and
selecting Local CD results in "I don't see one, load a driver" screen.
 Loading the SBP2 driver fails to find the CD.  RHL9 *does* find the
CD under the same circumstances.

Version-Release number of selected component (if applicable):
2.4.22-1.2115 (I think)

How reproducible:
Always

Steps to Reproduce:
1. Obtain Dell X200 laptop
2. (try to) Install Fedora Core 1 on it
3.
    

Actual Results:  Fails to find CD attached to IEEE-1394 internal
interface.

Expected Results:  Boot, and install.

Additional info:
Comment 1 Marty Shannon 2004-03-05 08:23:10 EST
This is still the case in FC2T1.

Update on RH9 support: it seems that the drive itself is not found,
even though the ieee1394 controller seems to be found.  However, there
are diagnostics that indicate that it has problems.  From syslog (klog):

SCSI subsystem driver Revision: 1.00
ohci1394: $Rev: 693 $ Ben Collins <bcollins@debian.org>
PCI: Found IRQ 11 for device 02:03.1
PCI: Sharing IRQ 11 with 00:1d.2
PCI: Sharing IRQ 11 with 00:1f.1
ohci1394_0: OHCI-1394 1.0 (PCI): IRQ=[11]  MMIO=[e0200000-e02007ff] 
Max Packet=[2048]
ieee1394: SelfID completion called outside of bus reset!
ieee1394: sbp2: Error logging into SBP-2 device
- login failed
ieee1394: sbp2: sbp2_login_device failed
scsi0 : IEEE-1394 SBP-2 protocol driver (host: ohci1394)
$Rev: 707 $ James Goodwin <jamesg@filanet.com>
SBP-2 module load options:
- Max speed supported: S400
- Max sectors per I/O supported: 255
- Max outstanding commands supported: 64
- Max outstanding commands per lun supported: 1
- Serialized I/O (debug): no
- Exclusive login: yes
Comment 2 Marty Shannon 2004-03-05 08:26:37 EST

*** This bug has been marked as a duplicate of 77259 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.