Bug 1170261 - Satellite 6 doesn't have a dropdown tab for RHEL 7 when using VMware ESXi as Compute Node, however the customer's VMware virtualization environment has RHEL 7 profiles. [NEEDINFO]
Summary: Satellite 6 doesn't have a dropdown tab for RHEL 7 when using VMware ESXi as ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning
Version: 6.0.6
Hardware: Unspecified
OS: Linux
high
high with 1 vote vote
Target Milestone: Unspecified
Assignee: Shlomi Zadok
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On: 1106969
Blocks: sat61-release-notes 1315277
TreeView+ depends on / blocked
 
Reported: 2014-12-03 16:03 UTC by Aaron Thomas
Modified: 2019-04-16 14:25 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1315277 (view as bug list)
Environment:
Last Closed: 2017-03-27 16:50:31 UTC
bkearney: needinfo? (mmccune)


Attachments (Terms of Use)
RHEL 7 is missing from the 'Guest OS' dropdown menu (209.37 KB, image/png)
2014-12-03 16:03 UTC, Aaron Thomas
no flags Details
Guest OS missing for VMware Compute Resource (209.37 KB, image/png)
2014-12-04 16:46 UTC, Aaron Thomas
no flags Details
rhel 7 option missed (169.62 KB, image/png)
2015-05-07 06:06 UTC, gaoshang
no flags Details

Description Aaron Thomas 2014-12-03 16:03:06 UTC
Created attachment 964189 [details]
RHEL 7 is missing from the 'Guest OS' dropdown menu

Description of problem:
-----------------------------------------
Satellite 6 doesn't have a dropdown tab for RHEL 7 when using VMware ESXi as Compute Node, however the customer's VMware virtualization environment has RHEL 7 profiles. 

Version-Release number of selected component (if applicable):
-----------------------------------------
6.0.6

How reproducible:
-----------------------------------------
easily reproducible 

Steps to Reproduce:
1. Add VMware as a Compute Resource
2. Attempt to provision a New Host using VMware as the Compute Resource and the dropdown 'Guest OS' menu does not display RHEL 7 as an option, however the customer has RHEL 7 available in VMware as a profile.

Actual results:
-----------------------------------------
RHEL 7 is missing from the 'Guest OS' dropdown menu when creating a new host on satellite 6.


Expected results:
-----------------------------------------
RHEL 7 is available in the 'Guest OS' dropdown menu when creating a new host on satellite 6.


Additional info:
-----------------------------------------
See attached screenshot

Comment 1 RHEL Product and Program Management 2014-12-03 16:13:54 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Aaron Thomas 2014-12-04 16:46:19 UTC
Created attachment 964753 [details]
Guest OS missing for VMware Compute Resource

Comment 4 Dominic Cleal 2014-12-05 16:38:00 UTC
What vSphere or ESXi environment precisely is configured as the compute resource?

Note that Satellite 6 does not currently support standalone ESXi servers (bug #1142861).

Comment 5 Aaron Thomas 2014-12-08 22:27:26 UTC
vCenter is configured as the compute resource, the configuration is not a standalone ESXi host.

Comment 6 Dominic Cleal 2014-12-09 08:18:52 UTC
(In reply to Aaron Thomas from comment #5)
> vCenter is configured as the compute resource, the configuration is not a
> standalone ESXi host.

Which version of vSphere, and which versions are the ESX hosts?

Comment 7 Dominic Cleal 2014-12-10 08:39:43 UTC
Corey, you're able to reproduce this?

Setting needinfo, as we still need versions.

Comment 9 gaoshang 2015-05-07 06:05:01 UTC
This bug still failed when testing against Satellite-6.1.0-RHEL-7-20150429.2, please check attached snapshot, thanks!

Comment 10 gaoshang 2015-05-07 06:06:24 UTC
Created attachment 1022936 [details]
rhel 7 option missed

Comment 11 Shlomi Zadok 2015-06-15 11:43:25 UTC
Digging into this a bit more...
It seems that the list comes from rbvmomi gem.
Satellite 61 rbvmomi version is 1.6 - 
Upstream 1.8+ uses rbvmomi ~> 1.8
(latest rbvmomi is 1.8.2)

The data on guest oses is coming from rbvmomi file: vmodl.db
I vote for updating to 1.8.2

Comment 14 Magnus Glantz 2015-06-17 09:48:39 UTC
We are hitting this as well. VSphere 5.1 and Sat 6.0 (ruby193-rubygem-rbvmomi-1.6.0-3.el6sat.noarch).

Comment 17 Bryan Kearney 2015-06-26 14:32:36 UTC
Delivered in Snap10

Comment 18 gaoshang 2015-07-14 01:19:30 UTC
I have verified this bug against Sat6.1.0-GA-SNAP12(Satellite-6.1.0-RHEL-7-20150707.4), but still failed.

According to Comment 15, after replaced vmodl.db, RHEL 7 can be shown in "Guest OS":

wget https://github.com/vmware/rbvmomi/blob/master/vmodl.db?raw=true -O vmodl.db

Comment 20 Shlomi Zadok 2015-08-23 08:38:51 UTC
Is is accurate

Comment 25 Bryan Kearney 2017-03-27 16:50:31 UTC
We do not plan on fixing this for Satellite 6.1. I am closing this out as WONTFIX. If you feel this was done in error, please feel free to re-open with additional information. This is fixed in 6.2.


Note You need to log in before you can comment on or make changes to this bug.