Bug 1171286 - Storage: Adding a new Storage Manager does not work. Crashes with the error - Error caught: [ArgumentError] wrong number of arguments (2 for 1)
Summary: Storage: Adding a new Storage Manager does not work. Crashes with the error -...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: 5.4.0
Assignee: Rich Oliveri
QA Contact: Milan Falešník
URL:
Whiteboard:
Depends On:
Blocks: 1171899
TreeView+ depends on / blocked
 
Reported: 2014-12-05 19:47 UTC by Aparna Karve
Modified: 2015-06-16 12:45 UTC (History)
5 users (show)

Fixed In Version: 5.4.0.0.11
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1171899 (view as bug list)
Environment:
Last Closed: 2015-06-16 12:45:55 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1100 normal SHIPPED_LIVE CFME 5.4.0 bug fixes, and enhancement update 2015-06-16 16:28:42 UTC

Description Aparna Karve 2014-12-05 19:47:37 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Aparna Karve 2014-12-05 19:51:12 UTC
The following error is seen on the console -

[----] F, [2014-12-05T19:26:53.495938 #88970:3fcfa9433bdc] FATAL -- : Error caught: [ArgumentError] wrong number of arguments (2 for 1)
/manageiq/vmdb/app/models/storage_manager.rb:34:in `initialize'
/.rvm/gems/ruby-1.9.3-p484/gems/default_value_for-2.0.3/lib/default_value_for.rb:138:in `initialize'
/manageiq/vmdb/app/models/storage_manager.rb:45:in `new'
/manageiq/vmdb/app/models/storage_manager.rb:45:in `new_of_type'
/manageiq/vmdb/app/controllers/storage_manager_controller.rb:94:in `create'

Comment 3 CFME Bot 2014-12-09 17:36:15 UTC
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/ff12fb2b91f7b0cd948a44a32aee2db7db8e0860

commit ff12fb2b91f7b0cd948a44a32aee2db7db8e0860
Author:     Richard Oliveri <roliveri@redhat.com>
AuthorDate: Mon Dec 8 16:26:53 2014 -0500
Commit:     Richard Oliveri <roliveri@redhat.com>
CommitDate: Mon Dec 8 16:26:53 2014 -0500

    Remove "initialize" method from StorageManager model.
    
    The initialize method of the StorageManager model class was calling super()
    and in so doing, not passing the proper args to the subclass. Given
    this was all the method did, the entire method has been removed.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1171286
    https://bugzilla.redhat.com/show_bug.cgi?id=1171899

 vmdb/app/models/storage_manager.rb | 4 ----
 1 file changed, 4 deletions(-)

Comment 4 CFME Bot 2014-12-09 17:41:01 UTC
New commit detected on cfme/5.3.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=29bb3e20fdbc7c54243bfa973b5913c5777b7968

commit 29bb3e20fdbc7c54243bfa973b5913c5777b7968
Author:     Richard Oliveri <roliveri@redhat.com>
AuthorDate: Mon Dec 8 16:26:53 2014 -0500
Commit:     Richard Oliveri <roliveri@redhat.com>
CommitDate: Tue Dec 9 12:39:02 2014 -0500

    Remove "initialize" method from StorageManager model.
    
    The initialize method of the StorageManager model class was calling super()
    and in so doing, not passing the proper args to the subclass. Given
    this was all the method did, the entire method has been removed.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1171286
    https://bugzilla.redhat.com/show_bug.cgi?id=1171899

 vmdb/app/models/storage_manager.rb | 4 ----
 1 file changed, 4 deletions(-)

Comment 6 Milan Falešník 2015-03-13 13:51:08 UTC
Assuming the error from constructor comes during save of the new storage provider, no such message appeared when creating a new one in 5.4.0.0.11. Therefore moving to VERIFIED but I'd like to have a response from Rich on this. If all of this is correct, then just clear the needinfo :)

Comment 7 Rich Oliveri 2015-03-13 15:36:44 UTC
Yes, that is correct.

Comment 9 errata-xmlrpc 2015-06-16 12:45:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1100.html


Note You need to log in before you can comment on or make changes to this bug.