Bug 1171756 - urw-fonts-1.10-1.fc22 blocks sendmail to build
Summary: urw-fonts-1.10-1.fc22 blocks sendmail to build
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: urw-fonts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-08 14:30 UTC by Jaroslav Škarvada
Modified: 2015-02-02 09:13 UTC (History)
4 users (show)

Fixed In Version: urw-fonts-3:2.4-20.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-21 12:28:39 UTC


Attachments (Terms of Use)

Description Jaroslav Škarvada 2014-12-08 14:30:34 UTC
Description of problem:
New urw-fonts blocks sendmail to build.

Version-Release number of selected component (if applicable):
urw-fonts-1.10-1.fc22

How reproducible:
Always

Steps to Reproduce:
1. Rebuilt sendmail or just cd into sendmail/doc/op and run 'ps2pdf op.ps'

Actual results:
ps2pdf op.ps op.pdf
Error: /invalidfont in /findfont
Operand stack:
   Times-Italic@0   --nostringval--   Times-Italic
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false
Dictionary stack:
   --dict:1182/1684(ro)(G)--   --dict:0/20(G)--   --dict:78/200(L)--   --dict:59/120(L)--

Expected results:
No error

Additional info:
Sendmail is probably not the only package broken, I also know about bug 1142817.

Comment 1 Jaroslav Škarvada 2014-12-08 14:34:04 UTC
It builds OK with urw-fonts 2.4-19.

Comment 2 Jaroslav Škarvada 2014-12-08 14:43:15 UTC
Sendmail buildroot for Fedora 21:
$ fc-match -s 'Times-Italic'
n021003l.pfb: "Nimbus Roman No9 L" "Regular"
wasy10.ttf: "wasy10" "Normal"
cmmi10.ttf: "cmmi10" "Regular"
d050000l.pfb: "Dingbats" "Regular"
s050000l.pfb: "Standard Symbols L" "Regular"
rsfs10.ttf: "rsfs10" "Roman"

Sendmail buildroot for Fedora 22:
$ fc-match -s Times-Italic
wasy10.ttf: "wasy10" "Normal"
esint10.ttf: "esint10" "regular"
stmary10.ttf: "stmary10" "Roman"
cmex10.ttf: "cmex10" "Regular"
cmmi10.ttf: "cmmi10" "Regular"
b018012l.pfb: "Bookman URW" "Light"
d050000l.pfb: "Dingbats" "Regular"
s050000l.pfb: "Standard Symbols L" "Regular"
rsfs10.ttf: "rsfs10" "Roman"

Comment 3 Jaroslav Škarvada 2015-01-15 13:20:25 UTC
The problem is caused by different font names. Sendmail documentation requires:

Times-Italic
Times-Roman
Times-Bold

These are provided by the following AFM files:
n019023l.afm - Times-Italic
n021003l.afm - Times-Roman
n021004l.afm - Times-Bold

E.g. in the n019023l.afm there previously was:
FontName NimbusSanL-ReguItal
FullName Nimbus Sans L Regular Italic
FamilyName Nimbus Sans L

Currently there is the following:
FontName NimbusSan-Ita
FullName Nimbus Sans Italic
FamilyName Nimbus Sans

It seems that the URW prefixes/suffixes are missing (e.g. L for laser).
That's why ghostscript cannot find the fonts.

Comment 4 Jaroslav Škarvada 2015-01-15 13:29:55 UTC
It seems you moved from urw-fonts to urw-core35-fonts. AFAIK urw-core35-fonts was "upstream" for urw fonts, i.e. what was provided by URW++ and urw-fonts contained modifications needed by ghostscript. Does it change? IIRC there was discussion about patching ghostscript to work with the urw-core35-fonts directly, but I don't know how far it went. CCing ghostscript maintainer.

Comment 5 Ngo Than 2015-01-21 12:28:39 UTC
there's new urw-font built in rawhide. it fixes the build failure in sendmail.
http://koji.fedoraproject.org/koji/taskinfo?taskID=8686765


Note You need to log in before you can comment on or make changes to this bug.