Bug 1142817 - cyrus-imapd-2.4.17-9.fc22 FTBFS: Error: /invalidfont in /findfont
Summary: cyrus-imapd-2.4.17-9.fc22 FTBFS: Error: /invalidfont in /findfont
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cyrus-imapd
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Šimerda (pavlix)
QA Contact: Fedora Extras Quality Assurance
URL: http://koji.fedoraproject.org/koji/ta...
Whiteboard:
Depends On: 1140865 1160132
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-09-17 13:00 UTC by Petr Pisar
Modified: 2015-03-03 23:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-03 23:49:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 919935 None None None Never
Red Hat Bugzilla 1147931 None None None Never

Internal Links: 919935 1147931

Description Petr Pisar 2014-09-17 13:00:53 UTC
cyrus-imapd-2.4.17-9.fc22 fails to build in F22 because generating manual pages fails:

+ make -C doc -f Makefile.dist
make: Entering directory '/builddir/build/BUILD/cyrus-imapd-2.4.17/doc'
mkdir -p man
for man in ../man/*.[1-9]; \
do \
	echo "=== $man ==="; \
	groff -man -Thtml $man > man/`basename $man`.html; \
done
=== ../man/arbitron.8 ===
=== ../man/chk_cyrus.8 ===
=== ../man/ctl_cyrusdb.8 ===
=== ../man/ctl_deliver.8 ===
=== ../man/ctl_mboxlist.8 ===
=== ../man/cvt_cyrusdb.8 ===
=== ../man/cyr_dbtool.8 ===
=== ../man/cyr_df.8 ===
=== ../man/cyr_expire.8 ===
=== ../man/cyr_synclog.8 ===
=== ../man/cyrus.conf.5 ===
=== ../man/deliver.8 ===
=== ../man/fetchnews.8 ===
=== ../man/fud.8 ===
=== ../man/idled.8 ===
=== ../man/imapd.8 ===
=== ../man/imapd.conf.5 ===
./../man/imapd.conf.5:1198: warning: numeric expression expected (got `f')
./../man/imapd.conf.5:1198: warning: numeric expression expected (got `f')
=== ../man/imclient.3 ===
=== ../man/imtest.1 ===
=== ../man/installsieve.1 ===
=== ../man/ipurge.8 ===
=== ../man/krb.equiv.5 ===
=== ../man/lmtpd.8 ===
=== ../man/lmtptest.1 ===
=== ../man/master.8 ===
=== ../man/mbexamine.8 ===
=== ../man/mbpath.8 ===
=== ../man/mupdatetest.1 ===
=== ../man/nntpd.8 ===
=== ../man/nntptest.1 ===
=== ../man/notifyd.8 ===
=== ../man/pop3d.8 ===
=== ../man/pop3test.1 ===
=== ../man/quota.8 ===
=== ../man/reconstruct.8 ===
=== ../man/rmnews.8 ===
=== ../man/sieveshell.1 ===
=== ../man/sivtest.1 ===
=== ../man/smmapd.8 ===
=== ../man/smtptest.1 ===
=== ../man/squatter.8 ===
=== ../man/sync_client.8 ===
=== ../man/sync_reset.8 ===
=== ../man/sync_server.8 ===
=== ../man/syncnews.8 ===
=== ../man/timsieved.8 ===
=== ../man/tls_prune.8 ===
=== ../man/unexpunge.8 ===
pod2html ../perl/imap/cyradm.sh > man/cyradm.1.html
Cannot find "Cyrus::IMAP::Admin" in podpath: cannot find suitable replacement path, cannot resolve link
pod2man ../perl/sieve/scripts/sieveshell.pl > ../man/sieveshell.1
pod2html ../perl/sieve/scripts/sieveshell.pl > man/sieveshell.1.html
rm -f groff-html-*.png pod2htm*
fig2dev -L png murder.fig murder.png
Error: /invalidfont in /findfont
Operand stack:
   basefontdict   Times-Roman
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1902   1   3   %oparray_pop   1901   1   3   %oparray_pop   --nostringval--   1885   1   3   %oparray_pop   1771   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   1854   2   4   %oparray_pop
Dictionary stack:
   --dict:1178/1684(ro)(G)--   --dict:0/20(G)--   --dict:111/200(L)--   --dict:3/12(L)--
Current allocation mode is local
Last OS error: Not a directory
GPL Ghostscript 9.14: Unrecoverable error, exit code 1
Error in ghostcript command
command was: gs -q -dSAFER -sDEVICE=png16m -r80 -g851x495 -sOutputFile=murder.png -
Makefile.dist:3: recipe for target 'dist' failed
make: Leaving directory '/builddir/build/BUILD/cyrus-imapd-2.4.17/doc'

Comment 1 Pavel Šimerda (pavlix) 2014-10-10 16:51:01 UTC
Somewhat similar to bug #921706.

Comment 2 Jaroslav Škarvada 2014-12-08 14:33:00 UTC
Problem is very probably caused by rebase of urw-fonts, bug 1171756 and bug 1160132.

Comment 3 Jaroslav Reznik 2015-03-03 16:18:13 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 4 Jason Tibbitts 2015-03-03 23:49:36 UTC
This builds fine in rawhide for me.  I don't think this build failure had anything to do with cyrus-imapd.


Note You need to log in before you can comment on or make changes to this bug.