Bug 117244 - IBM X31, kernel oops with >2.6.3-1.116 unless acpi=off
IBM X31, kernel oops with >2.6.3-1.116 unless acpi=off
Status: CLOSED DUPLICATE of bug 117044
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-01 17:41 EST by Patrick C. F. Ernzer
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the oops on kernel 2.6.3-1.116 (5.59 KB, text/plain)
2004-03-01 17:43 EST, Patrick C. F. Ernzer
no flags Details

  None (edit)
Description Patrick C. F. Ernzer 2004-03-01 17:41:10 EST
Description of problem:
Kernel oops at boot.

Version-Release number of selected component (if applicable):
2.6.3-1.116

How reproducible:
always

Steps to Reproduce:
1. boot a kernel newer than 2.6.3-1.91 (I did not necessarily have all
 rawhided kernels after 91, but 2.6.3-1.116 has the problem)
2. be sure not to have 'acpi-off' in the kernel line
3. watch it oops
  
Actual results:
Twofold (full trace attached):
a)
ACPI: Found ECDT
    ACPI-0180: *** Warning: The ACPI AML in your computer contains
errors, please nag the manufacturer to correct it.
    ACPI-0183: *** Warning: Allowing relaxed access to fields; turn on
CONFIG_ACPI_DEBUG for details.

b)
drivers/acpi/ec.c:357: spin_is_locked on uninitialized spinlock dfece7c8.
Unable to handle kernel paging request at virtual address 80315aa0
 printing eip:
Expected results:


Additional info:

acpi=off solves the problem, but as the X31 is quite widespread
internally, it would be a nice show off when on-site if ACPI worked
nicely ;-)

The ACPI warning also happened on 2.6.3-1.91.

As there was an LVM change after 2.6.3-1.91, ging back to that version
to do testing is painful. (I'm not sure if -91 did not have acpi
disabled by default)

Is there a chance we can get IBM to fix their ACPI AML?

Model:                      IBM X31
TYPE:                       2672-CXG
BIOS Version                2.04 (1QET66WW)
BIOS Date (Year-Month-Day)  2003-11-10
Embedded Controller Version 1.03
Comment 1 Patrick C. F. Ernzer 2004-03-01 17:43:30 EST
Created attachment 98177 [details]
the oops on kernel 2.6.3-1.116
Comment 2 Bill Nottingham 2004-03-02 00:58:21 EST

*** This bug has been marked as a duplicate of 117044 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:43 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.